Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 47792 - with image-loading off, no "show image" option
: with image-loading off, no "show image" option
Status: RESOLVED DUPLICATE of bug 47475
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: P3 normal with 6 votes (vote)
: Future
Assigned To: Stuart Parmenter
: Terri Preston
: Milan Sreckovic [:milan]
: 48549 64071 (view as bug list)
Depends on: 70938 73848
  Show dependency treegraph
Reported: 2000-08-05 22:50 PDT by Greg Roelofs
Modified: 2002-10-21 07:34 PDT (History)
11 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Greg Roelofs 2000-08-05 22:50:24 PDT
The "don't load any images" option appears not to have been worked on yet.  When
active, the right-button popup includes a useless "don't load this image" item
but no "show image" or "load image" item.  (In addition, there's no show-images
button on the main button bar, at least with the Modern skin.)

With "view image", a separate window is opened and the status bar claims it is
finished, but the image never shows up.  I've observed this with both JPEG and
PNG images so far.

I'm testing with the Linux talkback 2000-08-05-04-M17 nightly (but it should be
pretty much identical to 2000-08-04-14-M17), on Linux-2.2.17pre12-SMP / x86 /
Comment 1 Greg Roelofs 2000-08-05 22:57:34 PDT
Adding 4xp and correctness keywords.  Not sure if "ui" should also be added
(menu items).
Comment 2 Greg Roelofs 2000-08-05 23:27:19 PDT
See also bug 47794 for related right-button-context-popup problems.  The first
part of this bug (but not the "view image" failure) might be more appropriate
Comment 3 Sean Richardson 2000-08-06 21:56:17 PDT
Actually, "Show Images" appears on the View menu, as detailed in bug 43571, "no 
way to load images when automatic image loading is turned off".

On the other hand, it is always greyed out, no matter what setting is used
in the Advanced > Cookies and Images > Images section in the Prefs. To be more
specific, when "(*) Do not load any images" is active, and no images are 
displayed, "View Images" remains greyed out. As this bug is clearly about
context menu image-display options, the non-working main menu item must
be another bug - not finding it, though.

RFE Bug 35130, "Control of image loading", Future, asks for a "Show Image"
context menu item. 

Without a "Show Image" item, "View Image" will look like what the (naive)
user is looking for to get an image to appear. But it does what it has always
done, displaying the image in an otherwise empty window, and if it isn't loaded,
there is nothing to display. Not very freindly, but there it is. 

One of two things (short of implementing bug 35130's enhancement) would help,
the first much more than the second: 
(1) Force the image to be loaded when "View Image" is chosen, so there is
    something to display.
(2) Grey out or remove the "View Image" item when no images are loaded.
Comment 4 Gagan 2000-08-08 00:11:42 PDT
I don't think this is ImgLib, but is webshell. Cc'ing mscott...
Either way this might be too late for nsbeta3 but would let mscott add his
Comment 5 Scott MacGregor 2000-08-08 11:40:58 PDT
I agree I don't think this meets our beta3 criteria and I'd future this. I'm not
quite clear on what webshell would do with this information anyway.

(Sounds like we should take it out of the view menu if it's never going to be
enabled and that should be done for beta3 or RTM).
Comment 6 pnunn 2000-11-17 10:06:59 PST
*** Bug 48549 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Ruderman 2000-11-30 13:55:42 PST
"Show Images" in the View menu not working is bug 57505.
Comment 8 Jesse Ruderman 2000-11-30 13:59:00 PST
Is this bug a dup of bug 35130?
Comment 9 Doron Rosenberg (IBM) 2001-01-07 02:05:21 PST
*** Bug 64071 has been marked as a duplicate of this bug. ***
Comment 10 HJ 2001-01-08 05:22:08 PST
So, my bug 64071 is made a dup of this one. Now I at least know where to discuss
this problem. I'm using Opera as browser also, you know why? the speed. Simply
switch off imaga loading, on that specific window you are looking at, and then
switch back on. That's really handy you know. So I think we need to be able to
show the image, if the show images are turned off in preferences menu. You
already have yourself that option in context menu and a new window is opening
already at this point. Now we only need to see that image in this window, that's
all. When is future? 2001 or 2002 or even 2003???
Comment 11 pnunn 2001-03-19 14:22:48 PST
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Comment 12 Sean Richardson 2001-05-21 19:38:09 PDT
It is currently impossible to test this bug or any fix for it until bug 73848, 
"Image blocking no longer works", is fixed, so setting blocker.

This could be DUP'd onto bug 35130, "Control of image loading using context 
menus (Show Image, Reload Image)", if 35130 was broadened to apply to all 
circumstances where images do not appear. The functionality would be the same.

Bug 57505, "`Show Images' command not hooked up", does cover the second part
of the original report, and bugs should be about one thing, so removing
"and "view image" fails" from the summary.
Comment 13 WB 2002-03-30 16:48:42 PST
I vote for the 'Show Images' menu item to be enabled, because I, like HJ, also use Opera, and 
appreciate it's similar functionality, i.e., I have image auto-loading turned OFF, but then I can 
hit Shift-G on a given window, to simply load the images on a one-time basis.  FWIW, in opera, you can 
instead hit 'G' (no shift), if you want a given window to always load images during that 

A few years ago, I was able to surf the web fairly comfortably with just a 14.4k modem.  
Now, I have a 56k modem, and, you'd think that my speed would be a lot faster.  However, in the 
intervening years, web designers have added more images, scripts, and other enhancements to 
their pages, such that they are becoming slower and slower to load.  That is why now, I've set 'Auto 
load images' in Opera to *OFF*.  And that is why I think this feature should be added (back) to 
Mozilla and Netscape.
Comment 14 Brent Hugh 2002-08-15 07:33:27 PDT
I, too, vote for the 'Show Images' menu item to be enabled.  When I surf from 
home by modem, I always have images turned off and only hit "show images" when I 
come across a (usually ill-designed) web site that requires the images for 

This increases browsing speed by about 10 times, sometimes up to 100 times on 
particularly ill-designed pages.

Lack of this feature is the one single reason I am not using Mozilla as my main 
browser right now.

I might mention that the "show images" feature is far more useful/practical in 
speeding up and removing annoyances from day-to-day browsing than the 
much-ballyhooed "block popups" feature.

I don't bother to block popups--since I have images turned off, they're not very 
annoying (no content inside except a little text invariably reading "place image 
description text here") and don't slow down my browsing NEARLY to the degree 
dozens of unnecessary images on a page do.
Comment 15 Mark Bitterling 2002-08-20 17:13:19 PDT
How does this bug relate to bug 47475 ?
Comment 16 Greg Roelofs 2002-08-20 17:54:46 PDT
The current summaries are duplicates, but the original reports differ--this one
has always been about the right-button context menu, while bug 47475 originally
was about being able to left-click on an unloaded image and make it appear. 
Both are 4xp; the other one has some sort of patch attached.  There are also
some related-but-different issues in my original report here, but those may have
gotten resubmitted as separate bug reports.

Not having tried the patch for 47475, I can't tell if it addresses the original
report or the current summary.  Therefore I'm not marking this one dupe just

Comment 17 Eugene Savitsky 2002-09-16 13:25:19 PDT
Nominating for nsbeta1 - really needed feature for mobile users (such I :) ).
GPRS costs per each Mb and pictures are not the most needed for mobily working.
Comment 18 mozilla 2002-10-09 06:14:34 PDT
There are so many bugs/dups related to this 2yr old "NEW" bug, maybe if some of
us on the CC list vote for the bug, someone will actually take notice and fix it?

There must be a developer out there on dialup and not cable...
Comment 19 Jesse Ruderman 2002-10-21 02:12:38 PDT
This is a dup of bug 47475 (as moprhed, if comment 16 is correct).  If you want
left-clicking an image to load the image, please file a new bug.  (What would
happen if you clicked an image link?  Would it load the image or follow the link?)

*** This bug has been marked as a duplicate of 47475 ***
Comment 20 Greg Roelofs 2002-10-21 07:34:07 PDT
> If you want left-clicking an image to load the image, please file a new
> bug.  (What would happen if you clicked an image link?  Would it load
> the image or follow the link?)

Just FYI (I didn't report the left-click issue), the image loads if you click
within the generic-image icon, and the link loads if you click outside of it. 
(In 4.x, I think there may also be a dependency on whether you slide the mouse
in from the right or left, i.e., whether the icon or the non-icon area is the
first thing the pointer touches.)

If this is still an issue whenever the bookmarks architecture gets fixed, I'll
file a new one.  Until then, I'm afraid Mozilla is unusable (for me), anyway.


Note You need to log in before you can comment on or make changes to this bug.