Closed Bug 35130 Opened 25 years ago Closed 22 years ago

Control of image loading using context menus (Show Image, Reload Image)

Categories

(SeaMonkey :: UI Design, enhancement, P3)

x86
Windows 2000
enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 47475

People

(Reporter: hand, Assigned: bugzilla)

References

Details

When the browser fails to load an image or loads a corrupted version of an 
image, there is only way to make the browser try again is to right-click:view-
image, then reload.  Much preferable if the context menu for the image 
contains "Reload Image" or "Show Image" depending on the status of the image.

Show Image:
   - when an image has has not been loaded either because
     the browser has not started loading the image or
     because the last attempt at loading the image failed
     at while starting or half-way, this is a way of asking
     the browser to try again if it has given up or try
     harder, if the browser is trying, but the image is
     taking a long time to come over a slow network.

Reload Image:
   - when a corrupted image has been loaded, but the browser
     was not aware of, the user can intervene with a reload
     of just that image.
Changing component to XP Apps. I think they're responsible for the context menus
Assignee: troy → don
Component: Layout → XPApps
QA Contact: petersen → paulmac
qa to sairuh
QA Contact: paulmac → sairuh
.
Assignee: don → morse
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
This has nothing to do with image blocking so it ain't mine.  It's a request for 
an enhancement to the normal image loading that we always had.  Not sure who 
gets this so I'm reassigning to the owner of imagelib.
Assignee: morse → pnunn
Component: XPApps → ImageLib
QA Contact: sairuh → elig
Its a good idea. Thanks.
-P
Status: NEW → ASSIGNED
Target Milestone: --- → M20
Target Milestone: M20 → Future
Blocks: 61479
Would it make sense to also have a "show background image" option?  It would 
probably show up when you right-click in a blank area of a box where a 
background image hasn't loaded.
Summary: Control of image loading → Control of image loading using context menus (Show Image, Reload Image)
Oops, forgot to attribute that idea to Ken Arromdee (n.p.m.wishlist newsgroup).
See also bug 25071 for context menus involving background images.
QA Contact: elig → tpreston
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: ASSIGNED → NEW
Depends on: 75338
although helpful, this would not be useful enough to warrant a spot in the image
context menu. it is imparative that the image menu be kept brief as possible,
because [image as link] depends on it for its own brevity (16 items as redesigned).

i have posted the 2nd draft to the Context Menu Revision 2 document located:

http://mozilla.org/projects/ui/communicator/framework/contextmenus/cmrev2-2.html
You are of course right that having an extra spot in the image context menu may
raise a problem with cluttering the menu, but that is not what I am requesting.
      

I don't really want "Load Background Image" to be in the image context menu at
all.  I just want it to be available.  My suggestion, as I made in #75338, is
this: Use the *same* menu item for "View Background Image" and "Load Background
Image".  If the background image (for whatever definition of "background image"
the option currently uses) has not been loaded, then the menu should show "Load
Background Image".  If it has, then the menu should instead show "View
Background Image" in the same place.  Wouldn't this make it possible to have a
"Load Background Image" menu item *without* cluttering up any menus with an
extra slot?

(If this bug is only supposed to deal with the image context menu, as opposed to
any image loading from any context menu, tell me and I'll post the suggestion to
some more appropriate bug.)
*** Bug 138196 has been marked as a duplicate of this bug. ***
*** Bug 144318 has been marked as a duplicate of this bug. ***
not sure why this is assigned to me. this should belong to xpapps
Assignee: pavlov → sgehani
Component: ImageLib → XP Apps
QA Contact: tpreston → paw
Target Milestone: Future → ---
-> Blake
Assignee: sgehani → blaker
qa ==> sairuh@netscape.com
QA Contact: paw → sairuh
*** Bug 152925 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 47475 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.