Thunderbird 3 Address book keyboard shortcut wanted

RESOLVED FIXED in Thunderbird 3.0b3

Status

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: baffoni, Assigned: maxxmozilla)

Tracking

(Blocks 1 bug, {regression})

Trunk
Thunderbird 3.0b3
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

10 years ago
Now that the control-2 has been co-opted for switching to the second tab of email, I'd like to suggest we give it a new keyboard shortcut.  Some suggested keyboard shortcuts:

control-shift-a
control-shift-9  (less of a stretch to use right hand for number if you are used to the control-shift combo on the left side of the keyboard)
control-shift-2 (is kind of a stretch until you retrain hands to use control-shift on right sided of keyboard, cnsft9 is much more natural IMHO)

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3pre) Gecko/20090210 Shredder/3.0b2pre
Depends on: 466019
OS: Windows XP → All
Hardware: x86 → All
Assignee

Comment 1

10 years ago
Suggestions from bug 466019 :

> accel+B (address Book) is free


  -------  Comment #31 From  Phil Ringnalda (:philor)   2009-01-31 18:26:46
Mail.app uses cmd+opt+A, Windows Live Mail uses ctrl+shift+C-for-contacts,
Outlook Express uses ctrl+shift+B, Evolution uses ctrl+2.

So I guess, no matter what the OS there's a keyboard-accessible app that people
can use for mail :)
Reporter

Comment 2

10 years ago
If by saying "accel+B" you mean that the "B" key is available for the shortcut, then that sounds good to me.  That will at least be close to the OE command so people switching from OE should be less lost.


RE: Comment #31 (Quoted): What does that have to do with getting to the address book in Thunderbird?  Other than we probably shouldn't use the same key-command as a common app...  I suppose if there was a movement to abolish the addressbook within Tbird and strictly use an OS-supplied contact manager, that would make sense, but I haven't heard of such a movement....  In that case, I hope we would use Windows Contacts, Mac's contact manager (?) rather than another mail system's addressbook....


Thanks!
unclear why this dependss on bug 466019 instead of blocks.
Severity: enhancement → normal
Assignee

Comment 4

10 years ago
(In reply to comment #3)
because bug 466019 has caused this one ?
(In reply to comment #4)
> because bug 466019 has caused this one ?

Confusing though it can be, that relationship goes the other way around. The way I remember which way it goes is to think "the existence of this bug blocks bug 466019 from being correctly and completely fixed" or if I'm adding it in the other one, "having this bug correctly and completely fixed depends on having bug 478415 fixed."

(In reply to comment #2)
> RE: Comment #31 (Quoted): What does that have to do with getting to the address
> book in Thunderbird?

Context matters. The context in this case was "do we need to bother with a keyboard shortcut?" to which I replied that the primary clients on every single platform do provide one, so by not having one we would be telling people who wanted to be able to open their addressbook without a mouse or a slow trip through the menus that they should use the email client that they already got with their computer, rather than switching to us.
Blocks: 466019
No longer depends on: 466019
Keywords: regression
Assignee

Comment 6

10 years ago
Taking, I will propose the fix when bug 466019 will fully land.
Assignee: nobody → firefox
Status: NEW → ASSIGNED
Assignee

Comment 7

10 years ago
Posted patch Proposed fix v1 (obsolete) — Splinter Review
<!ENTITY addressBookCmd.commandkey "2"> is back as
<!ENTITY addressBookCmd.key "B">
Attachment #364794 - Flags: review?(mkmelin+mozilla)
Comment on attachment 364794 [details] [diff] [review]
Proposed fix v1

Sorry, ctrl+b is bolding in the composition window.
Attachment #364794 - Flags: review?(mkmelin+mozilla) → review-
Assignee

Comment 9

10 years ago
> Sorry, ctrl+b is bolding in the composition window.
doh!
how about ctrl+shift+B ?
seems to be free and matches Outlook/Outlook Express behavior
Yeah I guess that's free. Not the easiest of shortcuts, but as there aren't many available...
I'm receiving complaints about the removal of Ctrl+2 for the address book in TB3b2 from blind keyboard users as well. Requesting blocking. Marking dependent on the tabs metabug since this is obviously a result of the introduction of the tabbed interface.
Blocks: tabsmeta
Flags: blocking-thunderbird3?
Assignee

Comment 12

10 years ago
Changed to accel+shift+B
Attachment #364794 - Attachment is obsolete: true
Attachment #365943 - Flags: review?(mkmelin+mozilla)
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b3
Attachment #365943 - Flags: ui-review?(clarkbw)
Attachment #365943 - Flags: review?(mkmelin+mozilla)
Attachment #365943 - Flags: review+
Attachment #365943 - Flags: ui-review?(clarkbw) → ui-review+
Assignee

Updated

10 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/5c987717e2a0
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.