The names of the avm shell executables shall be 'avm' and 'avm64' on all platforms

RESOLVED FIXED in Q3 11 - Serrano

Status

RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: lhansen, Assigned: jsudduth)

Tracking

unspecified
Q3 11 - Serrano
Bug Flags:
flashplayer-qrb +

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
Following discussion it has been decided that the avm shell executable shall be named 'avm' on all platforms (ie 'avm.exe' on windows).  This harmonization is part of the effort to make the shell more usable as a scripting environment (especially once eval shows up).

On 64-bit systems the executable shall be 'avm64', since it often ends up in the same directory as the 32-bit executable in cross-platform development environments.

As far as I know we need to update:

 - VC2008 project files
 - Xcode project files
 - configure.py
 - build bots etc that already know what the name of the executable is
(Reporter)

Comment 1

10 years ago
Edwin suggests naming the directories eg 'Release64' rather than naming the executable 'avm64'.

Comment 2

10 years ago
yeah, I'm not so sure about "avm64". Would be nice to be able to rely on using "avm" as a scripting command in all cases; seems like it would be desirable to have "avm" refer to the best version for the platform.

Updated

10 years ago
Flags: flashplayer-qrb+
Target Milestone: --- → Future

Updated

9 years ago
Duplicate of this bug: 569628

Comment 4

9 years ago
Reactivating this discussion... any votes on "Release64/avm" vs "Release/avm64"?

IMHO the former is a better option, but I could be persuaded.
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Reactivating this discussion... any votes on "Release64/avm" vs
> "Release/avm64"?
> 
> IMHO the former is a better option, but I could be persuaded.

I'm happy either way, as long as we don't build fat binaries that will trick us into running the 64-bit binary when the OS thinks that's the right thing to do.

Comment 6

9 years ago
(In reply to comment #5)
> I'm happy either way, as long as we don't build fat binaries that will trick us
> into running the 64-bit binary when the OS thinks that's the right thing to do.

Agreed. Let's hear if QE has strong feelings. (Also, note that cleanup to the buildbot scripts will have to be done to enable this; it probably makes sense for someone familiar with that to do the heavy lifting there...)

Updated

9 years ago
Assignee: nobody → stejohns
Target Milestone: Future → flash10.2

Updated

9 years ago
Assignee: stejohns → jsudduth
(Assignee)

Comment 7

8 years ago
Created attachment 462255 [details] [diff] [review]
Bug 478714 XCode project patch

This is a 'preliminary' patch intended to elicit comments and feedback; there may be more to follow but this patch is focused on the XCode project file.

In order to build all avm shell executables as 'avm' the paradigm for building projects needed to be changed. Instead of several targets with different executable names, now there is one target with multiple configurations. This means that now you won't automatically get both a 32- and 64-bit shell when you build; also, the aggregated 32-64 shell target no longer exists. 

Architectures are i386/ppc for 32-bit and x86_64/ppc64 for 64-bit.

For 64-bit builds the sdk has been standardized on 10.5; 32-bit is still 10.4.

GCC has been kept at 4.0 for both 32- and 64-bit.
Attachment #462255 - Flags: review?(stejohns)
Attachment #462255 - Flags: feedback?(cpeyer)
(Assignee)

Comment 8

8 years ago
Created attachment 462257 [details] [diff] [review]
Bug 478714 Eclipse project patch

This is a 'preliminary' patch intended to elicit comments and feedback.

In order to build all avm shell executables as 'avm' the paradigm for building projects needed to be changed. There is still one target (shell) but now it has additional 64-bit configurations. The architecture for 32-bit continues to be i686; the new 64-bit configurations use x86_64. As before ppc isn't being built. For 64-bit builds the sdk has been standardized on 10.5; 32-bit is still 10.4. GCC has been kept at 4.0.1. New 64-bit launch configurations were added and the old ones were changed to find the renamed shell.
Attachment #462257 - Flags: review?(siwilkin)
(Assignee)

Comment 9

8 years ago
Created attachment 462260 [details] [diff] [review]
Bug 478714 VS Project patch

This is a 'preliminary' patch intended to elicit comments and feedback.

No new configurations were necessary. The shell was renamed to 'avm.exe'
Attachment #462260 - Flags: review?(wsharp)

Updated

8 years ago
Attachment #462255 - Flags: review?(stejohns) → review+

Updated

8 years ago
Attachment #462260 - Flags: review?(wsharp) → review+

Comment 10

8 years ago
(In reply to comment #8)
> Created attachment 462257 [details] [diff] [review]
> Bug 478714 Eclipse project patch

One issue I found: according to the indexer, editor and project properties, if I set one of the 64-bit configurations as the current build then __i386__ is still defined, rather than __x86_64__. (So the AVMSYSTEM_AMD64 ifdefs all appear as turned off).

However, when actually compiling,  __x86_64__ is defined.

Updated

8 years ago
Attachment #462257 - Flags: review?(siwilkin) → review+
(Assignee)

Comment 11

8 years ago
Created attachment 468822 [details] [diff] [review]
Updated-to-tip patch
Attachment #462255 - Attachment is obsolete: true
Attachment #468822 - Flags: feedback?(cpeyer)
Attachment #462255 - Flags: feedback?(cpeyer)
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 12

8 years ago
Patch up the VTune build script in windows-deep to match up to the new name of the shell. Patch 5111:6b59194ba03a
(Assignee)

Comment 13

8 years ago
Created attachment 470610 [details] [diff] [review]
Restore the aggregate 32- 64-bit Mac build functionality.

This patch restores the aggregate build target. It also rearranges the build configuration and target structures to be like they were before the last patch, while still accomplishing the goal of naming all the executables "avm". The major difference is that now instead of getting "shell" and "shell64" executables in the same folder, you will get "avm" execs in, for example, separate /Debug and /Debug64 folders.
Attachment #468822 - Attachment is obsolete: true
Attachment #470610 - Flags: review?(lhansen)
Attachment #468822 - Flags: feedback?(cpeyer)
(Assignee)

Comment 14

8 years ago
Whoops - should have reopened this before posting the patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

8 years ago
Comment on attachment 470610 [details] [diff] [review]
Restore the aggregate 32- 64-bit Mac build functionality.

Looks good - I tested it and everything was as expected.
Attachment #470610 - Flags: review?(lhansen) → review+
(Reporter)

Updated

8 years ago
Blocks: 591910
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.