Closed Bug 478776 Opened 12 years ago Closed 12 years ago

Please QA the revised What's New page (for 3.5)

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jslater, Assigned: stephend)

References

()

Details

Attachments

(2 files)

Hi Steven. Here's the first run page for your QA'ing pleasure. I should note that we may be tweaking this page further with some embedded video...will file separate bugs for that as that project develops.

Thanks!
Summary: please QA the revised first run page (for 3.1) → Please QA the revised first run page (for 3.1)
Target Milestone: 3.0 → 3.1
[1] I think the link to "Visit Firefox Support" can just be http://support.mozilla.com/ -- that's the way our global header and footer templates link to it.
[2] Also, weren't we getting rid of the "Click on the close button on this tab to go to your home page" functionality?  (I know it's there on http://en-us.www.mozilla.com/en-US/firefox/3.0.6/firstrun/, but still...)
(In reply to comment #1)
> [1] I think the link to "Visit Firefox Support" can just be
> http://support.mozilla.com/ -- that's the way our global header and footer
> templates link to it.
Sounds good to me.

> [2] Also, weren't we getting rid of the "Click on the close button on this tab
> to go to your home page" functionality?  (I know it's there on
> http://en-us.www.mozilla.com/en-US/firefox/3.0.6/firstrun/, but still...)
Sorry about the lack of clarity on this. I think we should remove that 'click to close' bar...I pinged Beltzner and he gave the thumbs up as well. So, let's remove it.

Thanks!
Both issues fixed in trunk in r22416.
Thx, Steven; I think we're good to go, here, so if you could just mark it FIXED, I'll verify.  Thanks!
Sadly, the SNL reference is lost on me because Hulu only works in the US. FIXED!
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Steven and I just realized that this page isn't actually the First Run page...instead, it's one of the states of the What's New page (the version for people who upgrade to 3.1.0).

Stephen, how should we handle this in terms of QA? Should I just rename this bug and call it a day, or should we open an entirely new bug and start again? (sorry)

Also, Pascal, I'm not sure if any l10n has started on this, but you should be in the loop on this, too.

Apologies to all-
If this is not the firstrun page, then it should be moved to the folder it belongs to (whatnew ?). When does the user see this page?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
As it turns out that we had actually been building the What's New page here instead of the actual First Run page, I've updated this bug to cover the What's New page.

What was at:
https://www-trunk.stage.mozilla.com/en-US/firefox/3.1/firstrun/
is now at:
https://www-trunk.stage.mozilla.com/en-US/firefox/3.1/whatsnew/

The actual firstrun page content is coming soon and will need a new QA bug when it's ready.

Sorry for the confusion on this. Just to be clear, the firstrun page isn't ready yet - what we had been working on was really the whatsnew page, which this bug now addresses.

To further complicate things, though, I think the "whatsnew" page on trunk is actually redirecting to the "firstrun" page, so this bug will have to wait on getting that fixed.
Summary: Please QA the revised first run page (for 3.1) → Please QA the revised What's New page (for 3.1)
Yeah, we added the whatsnew -> firstrun hack over in bug 427650 as a result of a last-minute miscommunication for a marketing project.
Here's a bit more background:

- first run page is for totally new installs

- what's new page is for upgrades, but that also include existing users who go from FF3 to 3.1 (or 2 to 3.1, even). That's why we've updated the 3.1.0 version of the What's New page to look a bit more like First Run...a lot of those people will be existing Firefox users, but we want the upgrade to 3.1 to feel like a big and exciting deal rather than just another minor upgrade so we spruced that version up a bit. (and ended up confusing things greatly in the process

To further complicate matters, there will eventually be another version of What's New for 3.1.1 and beyond that returns to the current text headline (instead of the big 3.1 graphic). We'll cross that bridge later, though.

Hope this helps-
(In reply to comment #10)
> Yeah, we added the whatsnew -> firstrun hack over in bug 427650 as a result of
> a last-minute miscommunication for a marketing project.

Is this permanent? Can we turn it off on trunk?
(In reply to comment #12)
> (In reply to comment #10)
> > Yeah, we added the whatsnew -> firstrun hack over in bug 427650 as a result of
> > a last-minute miscommunication for a marketing project.
> 
> Is this permanent? Can we turn it off on trunk?

Rolo, can we remove the redirect now?
Yep, let's take it out.
I'm not actually sure where the redirect is happening? Stephen, do you know who added it (and who can remove it)?
(In reply to comment #15)
> I'm not actually sure where the redirect is happening? Stephen, do you know who
> added it (and who can remove it)?

it's in .htaccess... just comment the rewrite out.
John, leaving this bug open for What's New is fine; in fact, I don't find any issues with the /whatsnew page (checked validation, links).
Just catching up with this - not sure what the issue is here, and don't quite remember the bug I worked on, but svn blame says this:

$ svn blame .htaccess  | grep 'lorchard'

 15960 lorchard@mozilla.com # Bug 439748
 15960 lorchard@mozilla.com RewriteRule ^(\w{2,3}(?:-\w{2}(?:-mac)?)?/)?firefox/3.0/whatsnew[/]?$ $1firefox/3.0/firstrun/ [NC,PT]
 15960 lorchard@mozilla.com 

That's probably the line you want commented out
Steven, assigning to you just to implement comment 18; re-assign the bug to me when you're done with that part, please.  Thanks!
Assignee: stephen.donner → steven
(In reply to comment #19)
> Steven, assigning to you just to implement comment 18; re-assign the bug to me
> when you're done with that part, please.  Thanks!

I think comment #18 is taken care of now.
I take it that this is because product-details on trunk has been updated to 3.0.7 in preparation for tomorrow's launch?
Steven: we should copy this over to https://www-trunk.stage.mozilla.com/en-US/firefox/3.5/whatsnew/, since 3.1 has been renamed/re-versioned to 3.5.
Assignee: steven → stephen.donner
Steven, when accessing this page using:

* Latest beta release (3.1 beta 3):

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729

-and-

* Latest 3.0.x branch release (3.0.7):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

I'm getting, "You’re running an unknown version of Firefox.

For security reasons, we recommend downloading the latest and greatest version."

instead of, "You’ve been updated to the latest version of Firefox."

I would expect that 3.0.7 would give me the latter, right?
Summary: Please QA the revised What's New page (for 3.1) → Please QA the revised What's New page (for 3.5)
I've brought over the version checking logic from the 3.0 whatsnew page in r23689. Should address comment #24.
(In reply to comment #26)
> Created an attachment (id=369017) [details]
> Screenshot showing 3.0.7 being read as 3.5, and then being offered the latest
> version

Reed, this version checking code looks like it goes back to r17942 and Bug 445717. Can you take a look?
(In reply to comment #27)
> Reed, this version checking code looks like it goes back to r17942 and Bug
> 445717. Can you take a look?

Yes, it's expected... this page is for 3.5 final, yes? 3.0.7 is the recommended version right now, so 3.5 != 3.0.7, so it tells you that there's a problem. Am I missing something?
Reed: If we're using 3.0.7 as the latest-version define/variable, then we should NOT be saying "For security reasons, we recommend downloading the latest and greatest version."
(In reply to comment #29)
> Reed: If we're using 3.0.7 as the latest-version define/variable, then we
> should NOT be saying "For security reasons, we recommend downloading the latest
> and greatest version."

Why not? You're going to a site meant for 3.5, which isn't 3.0.7. I guess I could allow for greater version numbers, but it seems correct to me right now.
So, 3.5 is hard-coded?  That makes sense -- I thought in the past, though, the "recommend downloading the latest and greatest version" was dynamic, based on a variable set to the latest version number (from product-details?).  What happens down the road when 3.5 is no longer the latest version, and it's hard-coded?  Will the What's New page no longer point people to, say, 3.5.x or 4.0?
(In reply to comment #31)
> What
> happens down the road when 3.5 is no longer the latest version, and it's
> hard-coded?  Will the What's New page no longer point people to, say, 3.5.x or
> 4.0?
I'm not sure what the proper technical solution is here, but the desired functionality is that this will be our What's New page for the entire 3.5 cycle (will almost certainly redesign it again for 4.0). But, once we start having dot releases we'll want the button to reflect that.
(In reply to comment #31)
> So, 3.5 is hard-coded?  That makes sense -- I thought in the past, though, the
> "recommend downloading the latest and greatest version" was dynamic, based on a
> variable set to the latest version number (from product-details?).

The latest version is from product-details, yes, but the current version comes from the path used to access the whatsnew page (/en-US/firefox/3.5/whatsnew/), so it's comparing 3.5 vs. 3.0.7 (what's in product-details). Since they aren't equal, it's saying that the user should upgrade.

> What happens down the road when 3.5 is no longer the latest version, and it's
> hard-coded?  Will the What's New page no longer point people to, say, 3.5.x or
> 4.0?

3.5 isn't hardcoded. It's all based on what product-details says is the latest Firefox version.
OK, with Reed's explanation in comment 33, I think (and am trusting, since I can't readily verify it for myself at this time) we're good to go here.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Target Milestone: 3.1 → 3.5
FYI, this page has changed pretty significantly from 3.1 to 3.5. I opened up a new bug - https://bugzilla.mozilla.org/show_bug.cgi?id=489646 - to track the new QA process.
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.