cannot empty gmail spam folder

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
VERIFIED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Kevin Brosnan, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs regression window], URL)

(Reporter)

Description

9 years ago
When gmail has been open for a day or more emptying the trash will often fail. This I see this issue on the trunk and 3.1b3pre nightly builds. 

Fails with an error similar to
Error: .111`$root/conversations/cat%40m.governance%40search%40cat/11ecd1e2c89e6a66/11edab3f2564daee
Source File: https://mail.google.com/mail/?ui=2&view=js&name=js&ver=6JKwbxQ1y0k&am=X7UYJ8T3cLkJBf_i0bY2UiQuWAk
Line: 702

1. Login to gmail and and leave it open for several hours
2. go to your spam folder, click delete all spam messages, ok on the dialog box
3. no messages are deleted, above error message is printed in the error console

Logging out and back in always fixes the issue.

Similar to bug 477101
Flags: blocking1.9.2?
I sometimes see a similar error when clicking on a thread in the inbox.   Once it happens, it keeps happening for that thread, and relogging fixes.
(Reporter)

Updated

9 years ago
Flags: blocking1.9.2? → blocking1.9.1?

Comment 2

9 years ago
Are we sure this bug is on our end? Is this a JIT issue? I don't think we can block on this without some more information and preferably a test case.
(Reporter)

Comment 3

9 years ago
Started up a session of todays Shiretoko build with javascript.options.jit.content false and logged into gmail. This is something that I run into every other day or so. If there is anything else I do to help diagnose the source of the issue please let me know.
Kevin: helping us with a regression range would be awesome.
Keywords: regressionwindow-wanted
Whiteboard: [needs regression window]
(Reporter)

Comment 5

9 years ago
I'm working on the regression window, right now I see the issue on the Firefox 3.1b1 release.

Additionally disabling jit.content did not help, I still ran into this issue on a nightly with jit.content false.
(Reporter)

Comment 6

9 years ago
Seeing this on Linux too. Can't reproduce on 3.1alpha1. Still working on narrowing the date.
OS: Windows Vista → All
Hardware: x86 → All
Get us a regression range and renominate? That would be great. For now I'll relnote this, as the workaround in comment 1 seems to work.
Flags: blocking1.9.1? → blocking1.9.1-
Keywords: relnote
(Reporter)

Updated

9 years ago
Duplicate of this bug: 483164
Ok, I hit it again. While trying to open a thread from the inbox:

Error: .120`$root/conversations/search%40inbox/11e1924aca0c4b24/11f67078a97c90e6
Source File: https://mail.google.com/mail/?ui=2&view=js&name=js&ver=HASWGW5R8Jg.en.O&am=X_m4pcD3cKHCBb3i0bR3UkDl7h4
Line: 722

After that I tried to delete messages from the spam folder and to empty the trash. Both actions failed with the same error message. Clicking on other threads in the inbox will open the message correctly. So only some of the messages are affected. Reloading the tab solved the problem. But that means I will be not able to turn off jit in-between, because it requires a reload too, right? I have to ask because just turning it off for content and clicking the message again, doesn't open it. So as long no real STR.

Comment 10

9 years ago
I hang when I clear spam every single time.

Comment 11

9 years ago
Also in latest Minefield 20090316 Gmail tasks has stopped working - shows compoletely empty. Opera Turbo shows Gmail tasks so it is not a problem at Gmail end.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 484241
I just saw it for the first time, with JIT disabled. I'm also running NoScript, although Gmail is in the whitelist. NoScript can cause troubles, also on whitelisted sites, so I don't know if this extension is the cause.
(Reporter)

Comment 14

9 years ago
This issue can be reproduced on a new profile given enough time. As I said in comment 5 disabling jit does not help.

Comment 15

9 years ago
I've emptied my spam folder a half-dozen times today, and have not had a single problem.  Still using Firefox 3.1 Beta 3.  I wonder if gmail fixed something on their end.

Comment 16

9 years ago
I can confirm that since yesterday in my FF 3.1 b 3, I have emptied gmail spam many times, and it worked all the time. So Gmail must have changed something at their end.
Cc'ing Erik in case he knows what might have changed with gmail (hope they didn't put in a workaround for a bug we haven't tracked).

/be

Comment 18

9 years ago
wfm for me too, using minefield

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090409 Minefield/3.6a1pre ID:20090409170752
Is this also fixed on branch? If not, do we know what patch fixed it on trunk?
Kevin, was you able to see this problem again in the last weeks? I'm not able to. Works fine for me since a couple of weeks.

Comment 21

8 years ago
Works for me also. Should be resolved.

Comment 22

8 years ago
WFM based on #21.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 23

8 years ago
It has been some time since I've seen this. Use to be a bi-weekly issue. v.
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
If this is WFM, removing relnote.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.