Closed Bug 478805 Opened 11 years ago Closed 9 years ago

Media load should begin when src attribute is set (calling load() no longer required)

Categories

(Core :: Audio/Video, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: BijuMailList, Unassigned)

References

()

Details

Changing VIDEO.src dont change the actual source file being played.

I assume this a regression from Bug 476731 

steps :-
1. go to attachment 346840 [details] 
2. user see http://www.double.co.nz/video_test/ascannerdarkly480.ogg
3. Change URL to http://www.double.co.nz/video_test/transformers480.ogg
4. click [Change URL to] button
5. click [play] button
6. let the movie play till you hear the sound

Result:-
user see 
* ascannerdarkly480.ogg being played 
* VIDEO.currentSrc = http://www.double.co.nz/video_test/ascannerdarkly480.ogg
* VIDEO.src = http://www.double.co.nz/video_test/transformers480.ogg

Expected:-
user see 
* transformers480.ogg being played 
* VIDEO.currentSrc = http://www.double.co.nz/video_test/transformers480.ogg
* VIDEO.src = http://www.double.co.nz/video_test/transformers480.ogg


FAIL
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) 
Gecko/20090216 Minefield/3.2a1pre


PASS
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) 
Gecko/20090214 Minefield/3.2a1pre
Thanks for the report, but this is actually a bugfix rather than a regression.  The HTML5 spec requires you to call the load() method on the element explicitly after changing the src attribute if the element has already begun loading:

4.8.10.2 Location of the media resource
[...]
If the src attribute of a media element that is already in a document and whose networkState is in the NETWORK_EMPTY state is added, changed, or removed, the user agent must queue a task that implicitly invokes the load() method on the media element, and ignores any resulting exceptions. The task source for this task is the media element's own media element new resource task source.

I mentioned this in bug 475868 comment 1, too.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> I mentioned this in bug 475868 comment 1, too.

right, sorry I misunderstood it.
Duplicate of this bug: 482470
Duplicate of this bug: 520758
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Changing VIDEO.src dont change the actual source file being played. → Media load should begin when src attribute is set (calling load() no longer required)
Fixing this is probably the same as fixing bug 485288.
Depends on: 485288
(In reply to comment #6)
> Fixing this is probably the same as fixing bug 485288.

I hope so. I just had a media player page break in Firefox because of this. It was working fine in Opera though.

I forgot this bug was still open and thought this was already fixed.
This was implemented in bug 485288.
Status: REOPENED → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → FIXED
(In reply to comment #8)
> This was implemented in bug 485288.

Thanks. Much appreciated. Seems to work fine now.
You need to log in before you can comment on or make changes to this bug.