Implement Upcoming Events block

VERIFIED FIXED in 3.0

Status

Websites Graveyard
spreadfirefox.com
--
blocker
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: abuchanan, Assigned: neilio)

Tracking

unspecified

Details

(Whiteboard: style, URL)

Attachments

(7 attachments)

(Reporter)

Description

9 years ago
On the news/events page, the block on the lower left, the Upcoming Events still needs to be implemented.
My mock, MOZ-014_SpreadFirefox_CR3rev_Page_5.jpg, has this on the mid-right section, just below the "Quick Wins" block; is that not correct?
(Reporter)

Updated

9 years ago
Duplicate of this bug: 473877
(Reporter)

Comment 3

9 years ago
correct, I have it in the right sidebar, under quick wins -> download counter -> upcoming events

MOZ-014_SpreadFirefox_CR3rev_Page_5.jpg

tomato.. wait that doesn't work when you type it...
Severity: normal → blocker
(Assignee)

Comment 4

9 years ago
Created attachment 364234 [details] [diff] [review]
Adds upcoming events HTML and CSS

Here's the changes to implement the upcoming events block. There are two new images needed which I will also attach to this bug.
Attachment #364234 - Flags: review?(buchanae)
(Assignee)

Comment 5

9 years ago
Created attachment 364235 [details]
Zipped copy of the new bg images

New bg images for upcoming events box (goes in img directory).
Attachment #364235 - Flags: review?(buchanae)
(Reporter)

Updated

9 years ago
Attachment #364234 - Flags: review?(buchanae) → review+
(Reporter)

Updated

9 years ago
Attachment #364235 - Flags: review?(buchanae) → review+
(Reporter)

Comment 6

9 years ago
i've checked in the attached patch + images to SVN in r22745

a couple things to note...

1)  the listed events aren't actual yet, Paul B. or I will have to set that up

2)  the background footer image ends in the middle of the block.  Neil is this something we can't repeat-y indefinitely?

Thanks

Comment 7

9 years ago
Loving the progress here, thanks Neil & Alex!

Is the background footer image related to the overall look and feel of the block?

It should look like a sheet of paper with shadowing behind it.  Also the gray line in between the listing and the "Upcoming Events" fads out in the design.

Attaching image of it...

Comment 8

9 years ago
Created attachment 364562 [details]
Events block design
(Assignee)

Comment 9

9 years ago
Created attachment 364697 [details]
Screenshot from Photoshop

Not sure what the issue is - I cut the image directly out of the mockup, so what you see is what you get, for the most part. The lines on the left and right sides of the box are very, very light, so they could just be getting lost in the difference between our displays.

Comment 10

9 years ago
Hey there:  Wanted to close the loop -- it looks fine now and it's with the same display.  So not sure what you all did :)

Alex:  Have you been able to work on getting the events to populate it?

Comment 11

9 years ago
Created attachment 365295 [details]
Upcoming Events CSS background

screenshot using xp screen resolution 1024x768 
marked with arrows missing css background images and tabs on the menu
(Reporter)

Comment 12

9 years ago
r22899 populates with actual events

NOTE: there is still a CSS issue with the bg image
Not sure if we want to keep bug 479343 separate from this.
(In reply to comment #13)
> Not sure if we want to keep bug 479343 separate from this.

Cut-'n-paste fail; so spammy today: really meant bug 481698.
(Reporter)

Comment 15

9 years ago
Neil, is there something you can do to fix the background image/css issue?  It'd be awesome if these blocks can be vertically expandable indefinitely.

If not, the alternative for this block would be to cut down the number of events entries listed.

Also, can you add some min-height to these blocks, so that when they have short/brief content they don't look offset?

Thanks!
Whiteboard: style
(Assignee)

Comment 16

9 years ago
Created attachment 368820 [details] [diff] [review]
Patch to fix background image issues

It's div-errific, but it works. This patch fixes the background image issue behind the events box.
Attachment #368820 - Flags: review?(buchanae)
(Assignee)

Comment 17

9 years ago
Created attachment 368821 [details]
New background images to go with above patch
Attachment #368821 - Flags: review?(buchanae)
(Reporter)

Comment 18

9 years ago
Comment on attachment 368820 [details] [diff] [review]
Patch to fix background image issues

yay
Attachment #368820 - Flags: review?(buchanae) → review+
(Reporter)

Updated

9 years ago
Attachment #368821 - Flags: review?(buchanae) → review+
(Reporter)

Comment 19

9 years ago
Thank you

r23696
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified FIXED using:

* Safari 3.2.2
* Firefox 2.0.0.20
* Firefox 3.0.7
* Firefox 3.1 beta 3
* Opera 9.64

IE 6 and 7 have issues: see bug 484925 for that.
Status: RESOLVED → VERIFIED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.