CSS2.1 IMG float: right property seems to be handled improperly.

RESOLVED DUPLICATE of bug 345369

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 345369
9 years ago
9 years ago

People

(Reporter: Chwiej Pawel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090212 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090212 Minefield/3.2a1pre

It looks like positioning is broken due to bad handling of float:right property.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.w3.org/Style/CSS/Test/CSS2.1/current/html4/t0905-c414-flt-wrap-01-d-g.htm
Actual Results:  
'Fail' span element is overlapping the green img.

Expected Results:  
There should be clean green rectangle visible.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345369
You need to log in before you can comment on or make changes to this bug.