Creating event/task with alarm on end/due date throws exception NS_ERROR_OBJECT_IS_IMMUTABLE in calAlarmUtils.jsm; no alarm dialog is displayed

RESOLVED FIXED in 1.0b1

Status

Calendar
Alarms
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b1
regression
Dependency tree / graph
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090220 Calendar/1.0pre (BuildID: 20090220070000)

Steps to Reproduce:
1. Start Sunbird with new profile
2. Open the new task dialog
3. Choose "Reminder > Custom..." to open the Reminders dialog
4. Add new reminder "15 minutes before the task ends" and press OK
5. Enable "Due Date" and set it to a date/time some minutes before current time
6. Press the "Save and Close" toolbar button

Actual Results:
The task is saved but no Alarm dialog is displayed. Error Console shows:

[[[
Error: [Exception... "'Can not modify immutable data container' when calling method: [calIAlarm::related]"  nsresult: "0x80460002 (NS_ERROR_OBJECT_IS_IMMUTABLE)"  location: "JS frame :: file:///E:sunbird/modules/calAlarmUtils.jsm :: cal_alarm_calculateAlarmDate :: line 80"  data: no]

STACK: 
1: [file:///E:sunbird/calendar-js/calUtils.js:1218] notifyFunc
2: [file:///E:sunbird/calendar-js/calUtils.js:1221] calListenerBag_notify
3: [file:///E:sunbird/calendar-js/calStorageCalendar.js:497] anonymous
4: [file:///E:sunbird/calendar-js/calStorageCalendar.js:445] anonymous
5: [null:0] null
6: [file:///E:sunbird/calendar-js/calTransactionManager.js:202] cT_doTransaction
7: [null:0] null
8: [file:///E:sunbird/calendar-js/calTransactionManager.js:71] cTM_createAndCommitTxn
9: [null:0] null
10: [chrome://calendar/content/calendar-item-editing.js:417] doTransaction

Source File: file:///E:sunbird/calendar-js/calUtils.js Line: 1218
]]]

Expected Results:
Task is saved and the Alarm dialog is displayed because the alarm is in the past.

Additional Information:
Same error happens if you enable the due date before setting the reminder or if you set the due date to a future date/time.
Flags: blocking-calendar1.0?
(Reporter)

Updated

9 years ago
Blocks: 479327
(Reporter)

Comment 1

9 years ago
Regression range: Works in Sunbird 1.0pre (20090130045750)
                  Fails in Sunbird 1.0pre (20090131031419)
                  
Checkins during regression range: https://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-01-30+04:57:50&enddate=2009-01-31+03:14:19

Seems to be regressed by the checkin for Bug 353492.
Blocks: 353492
(Assignee)

Updated

9 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+
(Reporter)

Comment 2

9 years ago
Also fails for events if the alarm is set for the end date.
OS: Windows XP → All
Hardware: x86 → All
Summary: Creating task with alarm throws exception NS_ERROR_OBJECT_IS_IMMUTABLE in calAlarmUtils.jsm; no alarm dialog is displayed → Creating event/task with alarm on end/due date throws exception NS_ERROR_OBJECT_IS_IMMUTABLE in calAlarmUtils.jsm; no alarm dialog is displayed
(Reporter)

Updated

9 years ago
Duplicate of this bug: 479597
(Assignee)

Comment 4

9 years ago
Created attachment 363563 [details] [diff] [review]
Fix - v1

What a drag, a missing "=" !
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #363563 - Flags: review?(ssitter)
(Reporter)

Comment 5

9 years ago
Comment on attachment 363563 [details] [diff] [review]
Fix - v1

r=ssitter
Attachment #363563 - Flags: review?(ssitter) → review+
(Assignee)

Comment 6

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/de91bde576a0>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 7

6 years ago
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.