If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

overflow:scroll does not take absolutely positioned div into account

RESOLVED INVALID

Status

()

Core
Layout
P3
normal
RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: Trevor Nuridin, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
Goto www.thedbo.com.au, choose winter.
The frame containing "thredco cams" & "snow report" will have sliders (which it
shouldn't, and part of "thredbo cams" image will not mask correctly with the slider.
Displayed correctly in IE5 & Navigator 4.7.3, but not in Mozilla M17.

If you also goto the "thredbo cams" link, the camera images are not aligned
correctly. Incorrectly aligned also in Navigator 4.7.3 (suspect all 4.x), but
works correctly in IE5.

Not checked in linux mozilla.
Changed URL. Confirming 20000820 WinNT4.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dividing up claytons bugs to triage.
Assignee: clayton → rods

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 3

17 years ago
I need to look into this somemore, so I will nominate it for now until I can 
take a better look

Comment 4

17 years ago
Created attachment 14037 [details]
small testcase

Comment 5

17 years ago
This page has an absolutely positionedDIV and the body tag doesn't take it into 
account when sizing itself and placing the scrollbars on the page.

Note: IE puts the scrollbars at the far right and bottom of the page (which 
looks nicer than just putting them around the size of the body that it would be 
if it were sizing to the content)
Assignee: rods → karnaze
Status: ASSIGNED → NEW
Summary: m17: mask / layout problems with thredbo.com.au site → overflow:scroll for body tag, put scrollbars in the wrong place
What IE is doing is wrong. What we are doing as far as scroll bars are concerned
is correct, except for them being below everything (known bug).

Although, the BODY seems to be sized a bit too big. Strange. David?
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase

Comment 8

17 years ago
Moving to m1.1 and reassiging to attinasi.
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.1

Comment 9

16 years ago
*** Bug 90636 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 90264 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 115293 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Confirmed in Mac/2001112011 (0.9.6). Setting All/All.

Note that this bug's URL value is no longer accessible.
OS: Windows 2000 → All
Hardware: PC → All

Comment 13

16 years ago
greg k,

as i'm aware bug 115293 had been re-opened and fixed by now.

Comment 14

16 years ago
Created attachment 67103 [details]
No image for Thredbo cam

Comment 15

16 years ago
Janus, how is that image relevant to this bug?

Comment 16

16 years ago
sorry greg, i didn't mean to send the attachment without my comments. 
please ignore the image/attachment for the time being. my relevant explanation
is coming up soon.

Comment 17

16 years ago
When I attached the "no Image for Thredbo cam" by accident today, I didn't
notice that the URL for this bug addressed "winter00".
I apologize for that mistake. 

FYI: I couldn't go to the URL mentioned above (winter00) as the webpage is
outdated. However, I checked http://thredbo.com.au/winter01/index.html

I checked Mozilla 0.9.6, Netscape 6.2, Navigator 4.7.4 and IE5 for Mac.
This is what I found out:

I saw nothing wrong with the scrollbar as the reporter mentioned in this case.
For "Thredbo cams":
Mozilla 0.9.6, IE5 and Navigator 4.7.4 can't display any images/picture
cams--broken image
Netscape 6.2 only shows link ( no frame/no image).
[See attachment: "no image for Thredbo cam"]

For Snow Report: the problem I found only on the text (the size)
Mozilla 0.9.6, Netscape 6.2 have similar problem to the text [see attachment: pic2]
See pic3 for Navigator 4.7.4 and pic4 for IE5


Comment 18

16 years ago
Created attachment 67194 [details]
Pic 2 - mozilla 0.9.6/netscape 6.2

Comment 19

16 years ago
Created attachment 67195 [details]
pic3 - navigator 4.7.4

Comment 20

16 years ago
Created attachment 67196 [details]
pic4 -IE5

Comment 21

16 years ago
Updating URL to page which shows this behavior. Actually there is overflow:auto
not overflow:scroll.

Another page: http://www.zenavtisni.cz/

Comment 22

15 years ago
*** Bug 160660 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
See comment 5 and comment 6.
Summary: overflow:scroll for body tag, put scrollbars in the wrong place → overflow:scroll does not take absolutely positioned div into account
So what's the bug here?  The fact that the <body> is a little too big?
This bug is invalid.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.