There is a white background around the Star panel

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Theme
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: whimboo, Assigned: Atsushi Sakai)

Tracking

({regression, verified1.9.1})

Trunk
Firefox 3.6a1
All
Mac OS X
regression, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed on 1.9.1 by bug 469631])

Attachments

(2 attachments)

Created attachment 363802 [details]
White background for star panel

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090223 Minefield/3.2a1pre

Opening the star panel shows an ugly white background around its boundaries. See the attachment.

Steps:
* Click twice on the star if the web page isn't bookmarked yet
* Press Cmd+D to bookmark the page
per Enn: maybe regression from bug 475343?
I would have sworn this was the same as bug 478784, except that seems to have landed before the 23rd.
Is this still a bug on trunk? If so, it should block.
Oh, it definitely is. Yuck. It's not a general transparent widgets bug, since the EV dropdown does work.
Backing out the Mac part of bug 475343 didn't fix it, so it's something else. Better find a regression range.
No longer blocks: 475343

Updated

10 years ago
Flags: blocking-firefox3.2?
(Assignee)

Updated

10 years ago
Duplicate of this bug: 480940
(Assignee)

Comment 8

10 years ago
Created attachment 364900 [details] [diff] [review]
Patch v1.0

Bug 469631 has been specified panel's background-color, but Page Bookmarked/Edit This Bookmark panel should be transparent.
Attachment #364900 - Flags: review?(dao)
Blocks: 469631

Updated

10 years ago
Component: Places → Theme
QA Contact: places → theme

Updated

10 years ago
Attachment #364900 - Flags: review?(dao) → review+
(Assignee)

Updated

10 years ago
Assignee: nobody → dev-null
Keywords: checkin-needed
pushed: http://hg.mozilla.org/mozilla-central/rev/e192f700fef4

Thanks for the patch!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3.2?
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1

Updated

10 years ago
Duplicate of this bug: 480969
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre ID:20090304021932
Status: RESOLVED → VERIFIED
Fixed on 1.9.1 by the landing of the adjusted patch in bug 469631.
Keywords: fixed1.9.1
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090416 Shiretoko/3.5b4pre ID:20090416030924
Keywords: fixed1.9.1 → verified1.9.1
Hardware: x86 → All
Whiteboard: [fixed on 1.9.1 by bug 469631]
You need to log in before you can comment on or make changes to this bug.