Switching mail and tasks tabs duplicates the account list in 'File' / 'Get New Messages for' menu

VERIFIED FIXED in 1.0b1

Status

defect
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: bugzilla.i.sekler, Assigned: Fallen)

Tracking

Trunk
1.0b1
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [not needed beta][no l10n impact])

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090223 Firefox/3.2a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090225 Lightning/1.0pre Thunderbird/3.0b3pre

With Lightning installed (--enable-calendar in .mozconfig), the list of accounts in the 'File' / 'Get New Messages for' dropdown menu gets doubled when switching mail and tasks tabs. If the Mail Toolbar is disabled, this applies also to the calendar tab.

This duplication doesn't persist across restarts of Thunderbird. I don't see it happening without Lightning.

Reproducible: Always

Steps to Reproduce:
1. Open the tasks tab (Ctrl+4)
2. Switch back to the mail tab(s)
3. Click on 'File' / 'Get New Messages for'
4. Switch back to the tasks tab again
5. back to 

or

1. Disable the Mail Toolbar ('View' / 'Toolbars' / '[ ] Mail Toolbar')
2. Open the calendar tab (Ctrl+3)
3. Switch back to the mail tab
4. Click on 'File' / 'Get New Messages for'
5. Switch back to the calendar tab again
6. back to step 3.

Actual Results:  
Each iteration in the loop adds a new duplicate of the account list in 'File' / 'Get New Messages for' dropdown menu.


Expected Results:  
No such duplication.


Bug filed on request <https://bugzilla.mozilla.org/show_bug.cgi?id=456940#c14>, confirmed by comment <https://bugzilla.mozilla.org/show_bug.cgi?id=456940#c12>.
Reporter

Updated

11 years ago
Version: unspecified → Trunk
Reporter

Comment 1

11 years ago
The last step of the first set of STR suffered an unintentional deletion: it should be

5. back to step 2

My apologies for the bugspam.
Component: Mail Window Front End → General
Product: Thunderbird → Calendar
QA Contact: front-end → general
Component: General → Lightning Only
QA Contact: general → lightning

Comment 2

10 years ago
Confirming this bug
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090415 Lightning/1.0pre (20090415) Shredder/3.0b3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All

Comment 4

10 years ago
Confirming - even with the initial STR (customize toolbar), but only with Lightning enabled...
Flags: blocking-calendar1.0?
Strange issue, cc'ing the Thunderbird team.
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Martin, can you look into this bug?
Assignee: nobody → mschroeder
Assignee

Updated

10 years ago
Whiteboard: [not needed beta][no l10n impact]
Reporter

Comment 7

10 years ago
Don't see the bug with

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1pre) Gecko/20090620 Lightning/1.0pre Thunderbird/3.0b3pre

SourceStamp=d285993e5dab

anymore, but the issue was still there in my previous local build (SourceStamp=9b0a71e2f698)

Probably solved by the landing of Bug 456385. Marking as FIXED for now.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Assignee: mschroeder → nobody
Target Milestone: --- → 1.0
Assignee: nobody → philipp
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.