Closed Bug 456940 Opened 14 years ago Closed 14 years ago

Customize Toolbar leads to doubled account list in "Get Mail" buttons drop down

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: Thunderbird_Mail_DE, Assigned: jminta)

References

Details

(Keywords: regression)

Attachments

(1 file)

Thunderbird build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1b1pre) Gecko/20080924032742 Shredder/3.0b1pre

1. Start Thunderbird and click the "Get Mail" buttons drop down. You'll get a correct drop down with a list of all existing accounts.

2. Customize the 3-pane-windows toolbar (no change necessary - only open the customize dialog and close the dialog with "OK"! - "Cancel" doesn't lead to the bug). Click the "Get Mail" buttons drop down again. You'll get the doubled accounts list in the drop down.
Linux too.
Flags: blocking-thunderbird3+
Keywords: regression
OS: Windows Vista → All
Hardware: PC → All
Target Milestone: --- → Thunderbird 3.0b2
A second activation of Customize Toolbar caused an additional duplication and looks like this will iterate each time Customize is activated and OK'd.
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0b2
Blocks: 413385
Joey, is this something you think might be due to the de-rdfification?

Either way, do you think you could take it on?
Sure, I think I understand what's going on here. If I'm right, it shouldn't be too difficult.
Assignee: nobody → jminta
Do the doubled entries persist across a restart?
(In reply to comment #6)
> Do the doubled entries persist across a restart?

No, a restart restores the drop down list to a normal single listing.
Target Milestone: Thunderbird 3.0b2 → Thunderbird 3.0b3
Attached patch patch v1Splinter Review
The patch pretty much explains itself. The popup's children stick around, but it loses its initialized state, so it tries to bring them back.
Attachment #358264 - Flags: review?(philringnalda)
Comment on attachment 358264 [details] [diff] [review]
patch v1

Looks good to me.
Attachment #358264 - Flags: review?(philringnalda) → review+
http://hg.mozilla.org/comm-central/rev/de9df60a34e6
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
I get a similar doubling of the account list - but in 'File' / 'Get New Messages for' - with Lightning installed.

STR:

1. Open the tasks tab (Ctrl+4)
2. Switch back to the mail tab(s)
3. Click on 'File' / 'Get New Messages for'

Is it a stuff for a new bug or would it fit into this one, if reopened?

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090223 Lightning/1.0pre Thunderbird/3.0b3pre
(In reply to comment #11)

Confirming this behaviour.
Just for the sake of completeness, more STR:

1. Disable Mail toolbar ('View' / 'Toolbars' / '[ ] Mail Toolbar')
2. Open the calendar tab (Ctrl+3)
3. Switch back to the mail tab
4. Click on 'File' / 'Get New Messages for'
5. Switch back to the calendar tab again
6. back to step 3.

Each loop adds an new duplicate of the account list in 'File' / 'Get New Messages for' as stated in comment #2 for the 'Get Mail' dropdown and the original STR.

Please reopen if appropriate.
Please file a new bug - and also note if there if it happens without lightning too.
Target Milestone: Thunderbird 3.0b3 → Thunderbird 3.0b2
(In reply to comment #14)
> Please file a new bug

Done: <https://bugzilla.mozilla.org/show_bug.cgi?id=480266>.
You need to log in before you can comment on or make changes to this bug.