if no windows were opened before entering PB, last window closed restored after exit

VERIFIED FIXED in Firefox 3.6a1

Status

()

P2
normal
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

({verified1.9.1})

3.5 Branch
Firefox 3.6a1
All
Mac OS X
verified1.9.1
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch in bug 481090])

(Assignee)

Description

10 years ago
found this when testing bug 480854, if there are no windows when we enter we restore the last closed window on exit of PB.  This is because of changes to getBrowserState to return the last closed window when no non-popup browser windows are open.  This isn't a bad change, but it leads to unexpected behaviour on Mac.  I think we should come up with a solution here.  Probably just setting _savedSessionState to transitionState in _onBeforePrivateBrowsingModeChange, but not sure what we should do here, 100%
Flags: blocking-firefox3.1+
(Assignee)

Updated

10 years ago
Priority: -- → P2
(Assignee)

Updated

10 years ago
Duplicate of this bug: 473429
(Assignee)

Updated

10 years ago
Depends on: 481090
(Assignee)

Updated

10 years ago
Whiteboard: [patch in bug 481090]
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Depends on: 481592
No longer depends on: 481592
Verified fixed with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre)
Gecko/20090304 Minefield/3.2a1pre ID:20090304021932

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre)
Gecko/20090304 Shiretoko/3.1b3pre ID:20090304022008
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
Hardware: x86 → All
Target Milestone: Firefox 3.1b3 → Firefox 3.2a1
You need to log in before you can comment on or make changes to this bug.