Closed Bug 481057 Opened 13 years ago Closed 12 years ago

Implement MEDIA_ERR_DECODE machinery

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: kinetik, Assigned: kinetik)

References

Details

Attachments

(1 file, 2 obsolete files)

We need to implement the part of the spec that covers the "if the media data is corrupted" case.  This was implemented (partially?) as part of another patch, but this part never made it into the tree for reasons I can't remember now.
Bug 449159 comment 47 and bug 449159 comment 51 (which I can't find a bug for, so I guess might have just gotten lost).

The Wave decoder already tries to fire an error for this case, but it's stubbed out in nsWaveDecoder::MediaErrorDecode.
Blocks: 491410
Flags: wanted1.9.2?
Attached patch patch v0 (obsolete) — Splinter Review
Initial patch.  Still need to make the Ogg decoder fire decode errors.  This patch also renames MEDIA_ERR_NONE_SUPPORTED to MEDIA_ERR_SRC_NOT_SUPPORT per the spec.
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Er, that'd be MEDIA_ERR_SRC_NOT_SUPPORTED.
Blocks: 505158
Flags: wanted1.9.2? → wanted1.9.2+
Blocks: 513405
Attached patch patch v1 (obsolete) — Splinter Review
Rebased against trunk, uses new test infrastructure, adds tests for Ogg decoder and constants.

Needs superview because it modifies web-exposed IDL.
Attachment #380699 - Attachment is obsolete: true
Attachment #399149 - Flags: superreview?(roc)
Attachment #399149 - Flags: review?(chris.double)
Duplicate of this bug: 491410
Comment on attachment 399149 [details] [diff] [review]
patch v1

Looks good. The only issue is whether we can make the test ogg file smaller.
Attachment #399149 - Flags: superreview?(roc) → superreview+
Attached patch patch v2Splinter Review
Same, but with the FLAC stripped out of the test file (saves ~200kB) and renamed from dirac_flac.ogg to dirac.ogg, some minor changes to the test, and slightly improved (but still not great) comments on gErrorTests and gDecodeErrorTests in manifest.js.
Attachment #399149 - Attachment is obsolete: true
Attachment #399153 - Flags: review?(chris.double)
Attachment #399149 - Flags: review?(chris.double)
Blocks: 515148
Attachment #399153 - Flags: review?(chris.double) → review+
http://hg.mozilla.org/mozilla-central/rev/55932a3a32aa
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Attachment #399153 - Flags: approval1.9.2?
Attachment #399153 - Flags: approval1.9.2? → approval1.9.2+
Duplicate of this bug: 523837
You need to log in before you can comment on or make changes to this bug.