[Mac OSX] Beta 3 build 1 are showing "Mozilla Firefox3.1b3" in window title

VERIFIED FIXED in mozilla3.1b3

Status

defect
VERIFIED FIXED
10 years ago
6 months ago

People

(Reporter: tchung, Assigned: rstrong)

Tracking

({regression})

3.5 Branch
mozilla3.1b3
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Reporter

Description

10 years ago
As a result of bug 468197, its seems that the beta 3 build 1 builds, are showing "Mozilla Firefox3.1b3" in the title of every new tab.    

Compared to Beta 2, new tabs there display "Mozilla Firefox 3.1 Beta 2"
Flags: blocking-firefox3.1?
Reporter

Updated

10 years ago
Depends on: 468197
The only thing I can think of that would cause this is Mac OS X not liking the new lines in Makefile.in here
http://mxr.mozilla.org/mozilla-central/source/browser/base/Makefile.in#58
Reporter

Comment 2

10 years ago
I cannot see this on windows. Seems like os x (linux) only.
Summary: Beta 3 build 1 are showing "Mozilla Firefox3.1b3" in new tabs → Beta 3 build 1 are showing "Mozilla Firefox3.1b3" in window title
On Linux (Ubuntu 8.10) the window title says: "Mozilla Firefox 3.1 Beta 3" when I focus on a new (Untitled) tab.
(In reply to comment #1)
> The only thing I can think of that would cause this is Mac OS X not liking the
> new lines in Makefile.in here
> http://mxr.mozilla.org/mozilla-central/source/browser/base/Makefile.in#58

Given the previous comments it sounds like you're right about this.
Indeed:
bitters-2:tmp bhearsum$ echo "3.1b3" | \
> sed -e '/pre/s/.*//g' -e '/[ab][0-9]/!s/.*//g' \
>       -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' \
>       -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g'
3.1b3

(Run on my Mac)
Reporter

Comment 7

10 years ago
sounds like a fix for mac only in build 2.   Thanks for the investigation folks.
Summary: Beta 3 build 1 are showing "Mozilla Firefox3.1b3" in window title → [Mac OSX] Beta 3 build 1 are showing "Mozilla Firefox3.1b3" in window title
So we're confirmed that Linux and Windows are properly titled?
Reporter

Comment 9

10 years ago
(In reply to comment #8)
> So we're confirmed that Linux and Windows are properly titled?

Yes.  it's a mac-issue only.
bhearsum, could you verify the following works since I don't have a Mac?
PRE_RELEASE_SUFFIX = $(shell cat $(srcdir)/../config/version.txt | \
  sed -e '/pre/s/.*//g' -e '/[ab][0-9]/!s/.*//g' | \
  sed -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' | \
  sed -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g')
No good:
bitters-2:tmp bhearsum$ echo "3.1b3" | sed -e '/pre/s/.*//g' -e '/[ab][0-9]/!s/.*//g' | sed -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' | sed -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g'
3.1b3

FWIW, the regexes here are confirmed to work on all 3 platforms:
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/package-name.mk#120

Comment 13

10 years ago
For something this complex, you will get better results using perl or python: sed is only portable for fairly trivial examples.
(In reply to comment #11)
> No good:
> bitters-2:tmp bhearsum$ echo "3.1b3" | sed -e '/pre/s/.*//g' -e
> '/[ab][0-9]/!s/.*//g' | sed -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' | sed
> -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g'
> 3.1b3
> 
> FWIW, the regexes here are confirmed to work on all 3 platforms:
> http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/package-name.mk#120

The only real difference between the patch (e.g. comment #10) and package-name.mk is package-name.mk uses |\ and the patch uses | \ for the new lines

After Beta 3 a version is python can be committed... there is already one in an obsoleted patch in bug 468197.

For Beta 3 let's just hardcode it to set PRE_RELEASE_SUFFIX to Beta 3... patch coming up
Interestingly, I couldn't make the package-name.mk version work outside of a Makefile. However, even after putting your latest regex in a Makefile it still didn't work Rob:
bitters-2:a bhearsum$ cat Makefile
VER = 3.1b3
PRE_RELEASE_SUFFIX = $(shell echo $(VER) | \
  sed -e '/pre/s/.*//g' -e '/[ab][0-9]/!s/.*//g' | \
    sed -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' | \
      sed -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g')
foo:
	echo $(PRE_RELEASE_SUFFIX)
bitters-2:a bhearsum$ make -f Makefile
echo 3.1b3
3.1b3
bitters-2:a bhearsum$ cat Makefile2
VER = 3.1b3

MOZ_PKG_LONGVERSION = $(shell echo $(VER) |\
                       sed -e 's/a\([0-9][0-9]*\)$$/ Alpha \1/' |\
                       sed -e 's/b\([0-9][0-9]*\)$$/ Beta \1/' |\
                       sed -e 's/rc\([0-9][0-9]*\)$$/ RC \1/')

foo:
	echo $(MOZ_PKG_LONGVERSION)
bitters-2:a bhearsum$ make -f Makefile2
echo 3.1 Beta 3
3.1 Beta 3
(In reply to comment #16)
> Interestingly, I couldn't make the package-name.mk version work outside of a
> Makefile. However, even after putting your latest regex in a Makefile it still
> didn't work Rob:
> bitters-2:a bhearsum$ cat Makefile
> VER = 3.1b3
> PRE_RELEASE_SUFFIX = $(shell echo $(VER) | \
>   sed -e '/pre/s/.*//g' -e '/[ab][0-9]/!s/.*//g' | \
>     sed -e 's/\(.*[0-9]\)a\([0-9]\+\)/ \1 Alpha \2/g' | \
>       sed -e 's/\(.*[0-9]\)b\([0-9]\+\)/ \1 Beta \2/g')
> foo:
>     echo $(PRE_RELEASE_SUFFIX)
> bitters-2:a bhearsum$ make -f Makefile
> echo 3.1b3
> 3.1b3
That is strange... it works for me and it isn't obvious what could be different about sed's handling on Mac OS X could be in this instance

Comment 19

10 years ago
sed on mac is BSD sed, not GNU sed. There are a host of differences.
Thanks Benjamin, I filed bug 481703 to use python to create the string.
Comment on attachment 365702 [details] [diff] [review]
actually hardcode the correct string

tested on Mac, works fine.  We should take this on the relbranch only.
Attachment #365702 - Flags: review?(mconnor) → review+
(In reply to comment #17)
> Created an attachment (id=365702) [details]
> actually hardcode the correct string

Pushed to the relbranch:
https://hg.mozilla.org/releases/mozilla-1.9.1/rev/3d9704097cd8
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Blocks: 468197
No longer depends on: 468197
Filed bug 481708 for a real fix to this.
Verified fixed on the 1.9.1 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (Build 2). I checked the same build on Mac Tiger and it looks fine on there as well - it properly shows "Mozilla Firefox 3.1 Beta 3" - without the quotes of course.
This is relbranch only so marking as verified too.
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3.1?
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3.1b3 → mozilla3.1b3
You need to log in before you can comment on or make changes to this bug.