Thunderbird Message Filters enabled with spacebar won't save enabled/disabled state on close of filter list window

RESOLVED FIXED in Thunderbird 11.0

Status

MailNews Core
Filters
--
minor
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Michael Baffoni, Assigned: aceman)

Tracking

({regression})

Trunk
Thunderbird 11.0
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b4pre) Gecko/20090305 Shredder/3.0b3pre

1) Create or identify mail filter under tools/mail filters
2) Use mouse to toggle mail filter status (e.g. enabled to disabled)
3) Close filter window
4) Open filter window - mail filter is toggled (e.g. disabled).
5) Use space bar to toggle status (e.g. disabled to enabled).
6) Closed Mail filter window
7) Open Mail filter window

Expected behavior:
8) Mail filter is toggled (e.g. enabled).

Actual behavior:
8) Mail filter is not toggled (e.g. disabled).
Michael, is this a regression from version 2?

sev > minor because there is a workaround (surprised you missed that)

note: the first filter selected requires two spacebars to toggle Enable checkbox
Severity: normal → minor
Component: Preferences → Filters
Product: Thunderbird → MailNews Core
QA Contact: preferences → filters
(Reporter)

Comment 2

8 years ago
I don't know if it is a regression in that I've never seen this error occur in TB2, it just worked normally in TB2.

Two spacebars did not fix this (it just removes the check).  One space toggles and a check appears, but it doesn't save it.  I don't know why a second spacebar, which would remove the check, would be correct or intuitive as a solution, or why this would be a work around (it isn't, when the check is removed, or enabled, it doesn't change state if it is done with the space bar).  No matter what state the filter is in, no amount of even or odd spacebar taps will change the state after closing and reopening.
the workaround is click. didn't mean to imply second spacebar works, as you found.

whether it fails in v2 is a nit but figured I'd ask because you probably wouldn't have noticed it if you didn't already know it worked in v2.  Your statement indicates it did, so this would be considered a regression.  So adding appropriate keyword
Keywords: regression

Updated

7 years ago
Duplicate of this bug: 549282
(Assignee)

Updated

6 years ago
Duplicate of this bug: 708241
(Assignee)

Comment 6

6 years ago
Created attachment 580506 [details] [diff] [review]
trivial patch

This fixes it for me. Can it be this simple?
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #580506 - Flags: review?(dbienvenu)
(Assignee)

Updated

6 years ago
Summary: Thunderbrid 3 Message Filters enable with spacebar won't save on close of window → Thunderbird Message Filters enabled with spacebar won't save enabled/disabled state on close of filter list window

Comment 7

6 years ago
Comment on attachment 580506 [details] [diff] [review]
trivial patch

thx, seems to work fine.
Attachment #580506 - Flags: review?(dbienvenu) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/9ca714b1e2f3
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
(Assignee)

Updated

5 years ago
Blocks: 388191
You need to log in before you can comment on or make changes to this bug.