dragging a tab to the desktop doesn't detach the tab

VERIFIED DUPLICATE of bug 475066

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 475066
9 years ago
9 years ago

People

(Reporter: juanb, Assigned: mano)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090304 Firefox/3.1b3 (20090304215011)

Dragging a tab out of the browser window is not working on Linux with fx3.1b3build1. The thumbnail appears as you drag the tab, and as you try to release it onto the desktop it disappears, but no new window is spawned.

Steps:
1. Launch Fx3.1b3build1 on Linux
2. Open more than one tab
3. Click on a tab title and drag it onto the desktop

Expected: Tab should detach from current window and load on a new browser window

Actual: Tab is not detached. A "dropped text.txt" file is created on the desktop, containing the url of the tab you just tried to detach.
Flags: blocking-firefox3.1?

Comment 1

9 years ago
relnote worthy?
Keywords: relnote
(Reporter)

Updated

9 years ago
Duplicate of this bug: 415127
Same happens for me with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090304 Firefox/3.1b3 ID:20090304214853

So it's cross-platform.
OS: Linux → All
Hardware: x86 → All
Summary: dragging a tab out of the browser window doesn't detach the tab on Linux → dragging a tab to the desktop doesn't detach the tab
Oh, and on Windows it's fine. The tab gets teared-off as a new window. I only get the denied cursor there (which is bug 463088).
Same behavior for build2 (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 ID:20090305133223)

Comment 6

9 years ago
on Solaris it also happens.A "dropped text.txt" file is created on desktop.
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
I was pretty sure there was already a bug open on this, but couldn't find it quickly, so assigning to Mano who might be able to dupe it off.
Assignee: nobody → mano
(Reporter)

Comment 8

9 years ago
This might be a dupe of 475066. I deferred to mano when he suggested opening a new one, after I had reopened the one previously mentioned.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475066
Bug 475066 has been re-opened. We should be tracking this there.
Flags: blocking-firefox3.1?
Status: RESOLVED → VERIFIED
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.