Closed Bug 481843 Opened 11 years ago Closed 9 years ago

Location bar should prefer bookmark keywords over history

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set

Tracking

(seamonkey2.1 wanted)

RESOLVED FIXED
Tracking Status
seamonkey2.1 --- wanted

People

(Reporter: robome, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.9.1b3pre) Gecko/20090304 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.9.1b3pre) Gecko/20090304 SeaMonkey/2.0b1pre

For long time I make extensive use of keywords in bookmarks.
Now since having this places thingy it seems they don't have priority over some mysterious automatic guessing which page the user wants to load.
A bookmark with keyword xyz should get used when entering xyz in the location bar. Instead very often if some page in the history (location bar or visited I don't have figured out yet) with xyz in the url is found, that one is loaded.

E.g. I've visited "http://sketchup.google.com/3dwarehouse/". When I now want to search for "sketch" using the keyword for the google search enginge "gg" and enter "gg sketch" I reproducably get above mentioned site, apparently because it contains "sketch". Entering for example "gg sketchme" correctly submits "sketchme" to google.



Reproducible: Always




Settings in Location Bar: Autocomplete from browsing history, Only match
locatios, Only on word boundaries, Automatically prefill the best match.
Version: unspecified → Trunk
I second that. In order for keyword search to be selected as expected (prior to anything) you have to select "Only at the beginning of the location or title" in the "Match" combobox in the "Location Bar" settings.
Oops, I forgot to mention browser version. The bug was introduced in 2.0a3.
I see this also. Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 SeaMonkey/2.0a3

I would suggest including keywords among the autocomplete candidates, with precedence over URLs and descriptions since the user specifically set them up to be launched by typing them.
Selecting "Only at the beginning of the location or title" is not helping. I have "http://gmail.com/" in location bar history, and keyword "g" for searching with Google. When I type "g gmail" in the location bar, "http://gmail.com/" gets selected.
I tried to reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090615 SeaMonkey/2.0b1pre and the information from the initial comment but failed. Can any of you reproduce with a current nightly build? If yes, please give exact steps to reproduce, ideally starting with a fresh profile. We need a good test case before we can confirm this bug.
(In reply to comment #5)
> I tried to reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1pre) Gecko/20090615 SeaMonkey/2.0b1pre and the information from the
> initial comment but failed. Can any of you reproduce with a current nightly
> build? If yes, please give exact steps to reproduce, ideally starting with a
> fresh profile. We need a good test case before we can confirm this bug.

This is really fun. Just tried with latest nightly and fresh profile. And I can't reproduce the originally mentioned sketchup example with the keyword gg for google but with the keyword go.
Also I tested it with the keyword bing for the new MS search engine. I entered "bing alpha beta" and executed. Then entered "bing alpha" and SeaMonkey submitted the former URL. Sometimes(!) it also happens for "bing beta". All in all I can't see a clear pattern but it definitely doesn't work as expected.

BTW, it might be bug 481836 that comes into play here, would be great if that could be ruled out.
I can reproduce this now with 'go' instead of 'gg', confirming.

As far as bug 481836 is concerned: Let's try again when that one is resolved or at least has a patch attached that has no issues.

Anyway, I think this is bad, requesting blocking 2.0.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2?
OS: Windows XP → All
Hardware: x86 → All
Isn't this also a dupe of bug 212605?
(In reply to comment #8)
> Isn't this also a dupe of bug 212605?

Only if we follow comment 3. This bug could be fixed without fixing bug 212605 (by making keywords work as intended without adding them to the search results). On the other hand, fixing that bug could possibly fix this one, too.
Not blocking 2.0 on this, if someone produces a patch then we will look at taking a fix for 2.0. Please nominate for wanted 2.1 if you wish.
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0-
If transfer of bookmarks to places will make it to 2.1 (bug 498596) this bug should probably be solved there as in Firefox keywords have precedence over history.
Flags: wanted-seamonkey2.1?
Depends on: SMPlacesBMarks
Flags: wanted-seamonkey2.1?
As with places bookmarks enable, keywords are displayed as the first search result, I believe we can mark this fixed by bug 498596 in current nightlies, SeaMonkey 2.1 Alpha 3 and later.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.