Closed Bug 212605 Opened 17 years ago Closed 9 years ago

Include Bookmark Keywords in autocomplete and give them priority over history

Categories

(SeaMonkey :: Location Bar, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jlayoj3121968, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030706
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030706

Bookmark keywords are not included in autocomplete results unless they have been
typed in previously. When they are included they are surrounded by "http://" and
"/" as if they were host names. (At least this happens with keywords with no
arguments. Keywords with arguments don't show up at all.)

Reproducible: Always

Steps to Reproduce:
1. Create a new simple bookmark keyword with no arguments.
1. Enter it in the location bar, noting the autocomplete entries.
2. Type it in again and look at the autocomplete entries again.

Actual Results:  
The first time the keyword is entered, it doesn't show up in the autocomplete at
all (unless you gave it a name that too closely matches a place you visited before.)

The second time, among the autocomplete results you will see the keyword,
surrounded by "http://" and "/" like it was a host name.

Expected Results:  
Even on first typing in the keyword in the location bar it should show up in the
autocomplete results, not made up like an URL.  Idealy I think bookmark keyword
matches should rank higher than URLs in typeahead, but at this point I'd be
happy to just have them show up properly.

Using 1.4 with no-GDI caching patch from bug 204374.
I realized this is better presented as an enhancement bug. Retitling to suit.
Severity: normal → enhancement
OS: Windows 98 → All
Summary: Bookmark keywords improperly handled in autocomplete → Include Bookmark Keywords in autocomplete and give them priority over history
No change as of 1.6.
Cross-references for integrating autocomplete and bookmarks:

Include in the Autocomplete list ...

Bug 101642 - Bookmark URLs, and list them on top
Bug 117967 - Bookmark names/titles
Bug 155320 - Bookmarks user clicks on
Bug 212605 - Bookmark Keywords, and don't prepend previously
	     typed keywords with 'http://'
Confirming.

Hardware:  PC -> All
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Please implement this easy, but useful feature. Also, please display on the right side description of keyword in the address bar.
In support of this enhancement: When I type a bookmark keyword [not tag] into location bar, then press enter, the URL of that keyword bookmark will definitely be loaded. It is weird that the actual URL about to be loaded is NOT shown in location bar dropdown list. But it's not the only thing that is not shown in the awesome bar dropdown though it should be... (bug 424797). The latter bug prevents effective use of the workaround for this bug 212605, namely that you can include the keyword in the title of your bookmark (e.g. "[wp] wikipedia quicksearch").  
Product: Core → SeaMonkey
Assignee: hewitt → nobody
QA Contact: claudius → location-bar
Edward, I believe this is a dupe of bug 392143?
(In reply to comment #7)
> Edward, I believe this is a dupe of bug 392143?

That's a Firefox bug, this is not.
Duplicate of this bug: 498086
Depends on: SMPlacesBMarks
Fixed by bug 498596 in current nightlies, SeaMonkey 2.1 Alpha 3 and later.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 460095
You need to log in before you can comment on or make changes to this bug.