Gmail IMAP label folder's unread count it not automatically updated

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Michael A. Puls II, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Opera/10.00 (Windows NT 5.1; U; Edition Turbo; en) Presto/2.2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090305 Shredder/3.0b3pre

In the Gmail webmail interface, I have this filter set up:

Matches: to:(test@example.org)
Do this: Skip Inbox, Apply label "test"

In Gmail IMAP with Thunderbird, when a new message matching that filter comes in, I expect the unread count on the right side of *both* the [Gmail]/All Mail and test folders to be updated.

Actual result:

The unread count on the right of the test folder doesn't update at all unless I manually select the folder. This is useless. It should update right away like [Gmail]/All Mail does.

Reproducible: Always
Do you have TB set to check the specific folders for new messages?
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.imap
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Do you have TB set to check the specific folders for new messages?

No. Thought all folders were automatically checked and didn't know there was an option to control it. Found it under the properties for each of my 16 folders and enabled it for each one though. Will see if it helps.
(Reporter)

Comment 3

9 years ago
O.K. Setting every folder to "check this folder for new messages" greatly helps the situation. (Is there any way to do that for all folders at once?)

However, I'm still seeing instances where the unread count for [Gmail]/All Mail will update, but none of my other folders show that they have any unread messages. Could this be because "Check this folder for new messages" only works when you manually check for all messages or when Tbird automatically checks at the set interval, but not for new messages detected via IDLE?

Still trying to pin down exactly when it happens.
How about providing an IMAP log of getting new messages?
<https://wiki.mozilla.org/MailNews:Logging>

GMail is known to have problems in its IMAP implementation.
(Reporter)

Comment 5

9 years ago
Will keep logging enabled so that if it happens, I'll have something to show.
Blocks: 402793

Comment 6

9 years ago
(In reply to comment #3)
> However, I'm still seeing instances where the unread count for [Gmail]/All Mail
> will update, but none of my other folders show that they have any unread
> messages. Could this be because "Check this folder for new messages" only works
> when you manually check for all messages or when Tbird automatically checks at
> the set interval, but not for new messages detected via IDLE?

Do they update if you wait for the check interval to expire?  Thunderbird only maintains a few connections per account, and each connection can only be IDLING in one folder at a time.  When the check interval completes, the connections will be reused to check the remaining folders.
I think one connection always returns to the INBOX to IDLE, but I do not how, or if, the other connections are distributed to IDLE.  (I would expect one IDLE connection on the currently selected folder, if there is one.)
(Reporter)

Comment 7

9 years ago
When this happens, clicking "Get Mail" fixes everything.

But, I found out exactly when this happens. The problem is caused by all the label folders not be checked for new messages when I select "[Gmail]/All Mail" and "[Gmail]/All Mail" not being checked for new messages when I select "some label folder". But, that's understandable as there's no option to sync things that way. (Just didn't realize how much I was selecting "[Gmail]/All Mail".)

With "Check this folder for new messages" set for every single folder, everything works as intended. Thanks Joshua and Brian.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.