Closed Bug 482149 Opened 12 years ago Closed 12 years ago

Today pane splitter still showing when pane is hidden in certain cases

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: ssitter)

References

Details

Attachments

(1 file)

From bug 460252:

[*] Close the Today Pane using the [X] button on top - splitter still
displayed.

[*] Close the Today Pane using the status bar button, restart Thunderbird, open
Today Pane using the status bar button - only splitter is displayed, pane is
still collapsed. Additional click on the grippy is required to display the
Today Pane.

This seems to happen randomly for me. All three methods use the same <command> element so I am not sure why this is happening.
I can reproduce the two points at will.
When I collapse the Today Pane using the [x] button, it also looks like the grippy points in the wrong direction, not noticing the collapsing sidebar content...

Why is the grippy there in the first place? Is it only hidden for other sidebars like the Contacts sidebar in the Compose window?
Attached patch patch v1 β€” β€” Splinter Review
This patch fixes the issues mentioned above for me and obsoletes Bug 390982. The only issue I still see is the one reported in Bug 430090.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #366676 - Flags: review?(philipp)
Comment on attachment 366676 [details] [diff] [review]
patch v1

Looks good, r=philipp
Attachment #366676 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/93e00b1849dc>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Duplicate of this bug: 390982
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.