Today Pane Integration in the new Thunderbird tab model (currently not available in mail tab)

RESOLVED FIXED in 1.0b1

Status

defect
P1
major
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

(Depends on 1 bug, {calendar-integration})

Bug Flags:
blocking-calendar1.0 +
tb-integration +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
With moving the calendar mode and task mode content into it's own tab (Bug 402365) the Today Pane is no longer visible in mail mode.

In my opinion it might be better to get rid of the mode dependent Today Pane and its displaying inside the tab. Instead the Today Pane could be part of the main window that can be enabled regardless of what tab is currently opened or displayed.

Comment 1

11 years ago
Sounds good for me.
(Reporter)

Comment 2

11 years ago
What I had in mind seems to be almost the same as described at
https://wiki.mozilla.org/Thunderbird:Calendar_Integration#Today_Pane_Integration
(Reporter)

Updated

11 years ago
Duplicate of this bug: 463426
(Reporter)

Comment 4

11 years ago
Confirming based on Comment #1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: tb-integration?
OS: Windows XP → All
Hardware: PC → All
Summary: Today Pane Integration in the new Thunderbird tab model → Today Pane Integration in the new Thunderbird tab model (currently not available in mail tab)
Raising priority, because it's a prominent calendar feature.
Flags: blocking-calendar1.0+
Priority: -- → P1
(Reporter)

Updated

11 years ago
Duplicate of this bug: 463587
I think we need some way of solving this problem before integrating, yes.
Flags: tb-integration? → tb-integration+

Comment 8

11 years ago
How are we going to proceed with this issue?
Will there be a right-hand-sidebar -provided from Thunderbird - that we can overlay into?.
If yes I would like to point out that the today-pane is designed to be available in all tabs (formerly modes) and may be switch on and off and configured tab-independently. This was implemented with bug 389150 because there was a big demand in the community for it. I personally can't see why the situation about this should have changed meanwhile.
I talked with Christian about this topic. He generally agreed with me but voted for changing the defaults of the today-pane, so that it should be switched off by default in all three tabs.

Comment 9

11 years ago
>Will there be a right-hand-sidebar -provided from Thunderbird - that we can
>overlay into?.

I have mentioned this sidebar only because I have heard about plans going on in this direction. To implement the todaypane in the mail-tab we would of course not necessarily need it - we just have to know if there will be one provided or not.
(Reporter)

Comment 10

11 years ago
The main request in Bug 389150 was to have the Today Pane available in the calendar and task mode too. In my opinion the support in the new tab model doesn't require a mode dependent today pane as it was implemented in Lightning 0.9. I think it would be sufficient if the today pane could be switched on/off independent of whatever tab or tab kind (mail, calendar, tasks, contacts, ...) is displayed.

Comment 11

11 years ago
I would like to show the today pane when the mail tab is showing but not when the calendar tab is showing because the today pane uses too much space in month view.  I wouldn't want to manually toggle the today pane every time I click on the mail or calendar tabs.
> Will there be a right-hand-sidebar -provided from Thunderbird - that we can
> overlay into?

Yes I think we should be providing sidebar space inside the Thunderbird mail tab

> If yes I would like to point out that the today-pane is designed to be
> available in all tabs (formerly modes) and may be switch on and off and
> configured tab-independently. This was implemented with bug 389150 because
> there was a big demand in the community for it. I personally can't see why the
> situation about this should have changed meanwhile.
> I talked with Christian about this topic. He generally agreed with me but voted
> for changing the defaults of the today-pane, so that it should be switched off
> by default in all three tabs.

I might be confused with what you're asking, but this seems like the right approach to me.  Hopefully I'll get to chat with Christian about this soon to clear it up.
Is there a thunderbird bug on implementing the sidebar container? It would be pretty important to identify and push that bug forwards. Please set dependencies as appropriate if you find it.
(Assignee)

Updated

11 years ago
Assignee: nobody → Berend.Cornelius
I don't believe there is one.  I assumed this would be it.
Severity: normal → major

Comment 15

11 years ago
Any progress on this?
Removing this from the Main Page really limits the effectiveness of lightning.

Comment 16

10 years ago
I want the Today Pane back in the main mail view also!
(In reply to comment #13)
> Is there a thunderbird bug on implementing the sidebar container? It would be
> pretty important to identify and push that bug forwards. Please set
> dependencies as appropriate if you find it.

I don't think there's such a bug. Someone who knows what it should look like, please file one.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 475255

Comment 19

10 years ago
I just pointed out to Fallen in #maildev an extension of mine: xSidebar for Thunderbird
https://addons.mozilla.org/en-US/thunderbird/addon/10000
http://xsidebar.mozdev.org/tsidebar/index.html

This extension is MPL/GPL/LGPL (since it's mostly code copied from Firefox).
(Assignee)

Updated

10 years ago
Depends on: 476154
I have filed bug 476154 for implementing the sidebar in Thunderbird.
No longer depends on: 476154
Duplicate of this bug: 476183
Assignee: berend.cornelius09 → philipp
Depends on: 476154
Whiteboard: [needed beta][no l10n impact]
Posted patch Fix - v1 (obsolete) β€” β€” Splinter Review
This patch takes care of the temporary solution. Sorry about all the "changed" lines, hg qdiff -w is failing on me. All I do on the mail side is to add a <hbox> around the tabmail, the rest is indentation changes.

I'd like to see this in the respin for beta 2, since we would like to have the today pane in our milestone build that fits with beta 2.

r=me for the calendar changes, they are so minor.
Attachment #363596 - Flags: review?(bugzilla)
Posted patch Fix - v2 (obsolete) β€” β€” Splinter Review
I've tried many combinations of -w and -b but to no avail. Since I'm changing these lines anyway, I thought I'd correct the indentation for all elements below the tabmail-container too.
Attachment #363596 - Attachment is obsolete: true
Attachment #363601 - Flags: review?(bugzilla)
Attachment #363596 - Flags: review?(bugzilla)
Posted patch Fix - v3 β€” β€” Splinter Review
Heh, I should review my changes better. This patch also moves the calendar splitter as appropriate!
Attachment #363601 - Attachment is obsolete: true
Attachment #363602 - Flags: review?(bugzilla)
Attachment #363601 - Flags: review?(bugzilla)
Status: NEW → ASSIGNED
Comment on attachment 363602 [details] [diff] [review]
Fix - v3

+  <hbox id="tabmail-container" flex="1">

We should put an XXX statement before this line stating that this is a temporary extension point until we implement sidebar contains, and reference the relevant bug so people know what to follow.

Its a bit of a shame we'll have a "block" on blame due to the whitspace restructure, but I think that's definitely needed.

r=me on the mail/ changes for the extension integration point. 

From the lightning point of view, there's two comments I have:

- Firstly, the today pane is now being shown as tab-independent but its state is tab-dependent. This is weird.

- Secondly, the splitter is always shown even with the pane "hidden", I cannot get rid of it, like I can with SeaMonkey's sidebar or the Contacts Sidebar in Thunderbird. This will annoy some people (me for one!).

However, they are just my comments, and I'm not doing review on the calendar/ part.
Attachment #363602 - Flags: review?(bugzilla) → review+
(In reply to comment #25)

> - Firstly, the today pane is now being shown as tab-independent but its state
> is tab-dependent. This is weird.
I agree its a bit wierd, but unless we put all today pane elements into each kind of tab and take care which today pane we are updating, I don't see a good solution for this. In the past users have requested the today pane to be mode dependant.

I've noticed we will have the same problem for the new menu entries.

> - Secondly, the splitter is always shown even with the pane "hidden", I cannot
> get rid of it, like I can with SeaMonkey's sidebar or the Contacts Sidebar in
> Thunderbird. This will annoy some people (me for one!).
I agree, I'll take care of this before checkin. I guess I didn't look close enough.
We're tagging the release in 2 hours.  I'd like to see this get in as a stop gap measure, however I can't block the whole release on this.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/fab45ddceb14>

I'll leave this open to fix Standard8's "Secondly" comment, I just wanted to get this checked in for the tb3b2 release.
Target Milestone: --- → 1.0
Additional fix for showing the splitter together with the today pane. Requesting review to be sure everything is ok.
Attachment #363739 - Flags: review?(ssitter)
(Reporter)

Comment 30

10 years ago
Comment on attachment 363739 [details] [diff] [review]
Fix showing splitter - v1

I tested and found some issues. Don't know if they are caused by this patch or not:

[*] Close the Today Pane using the [X] button on top - splitter still displayed.

[*] Close the Today Pane using the status bar button, restart Thunderbird, open Today Pane using the status bar button - only splitter is displayed, pane is still collapsed. Additional click on the grippy is required to display the Today Pane.
Stefan,

I could sometimes reproduce this issue, but it happend quite unpredictably. All three methods use the same command to toggle the visiblity, so I'm not sure why its differing.

Comment 32

10 years ago
It is working in the latest beta :-)
(Reporter)

Comment 33

10 years ago
Comment on attachment 363739 [details] [diff] [review]
Fix showing splitter - v1

r=ssitter to improve current situation; with follow-up patches/bugs for the issues mentioned above
Attachment #363739 - Flags: review?(ssitter) → review+
Filed bug 482149.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/694a773f7a8a>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.