HTML not getting copied and pasted properly in Gmail compose window

RESOLVED DUPLICATE of bug 480972

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 480972
9 years ago
9 years ago

People

(Reporter: Jay, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090310 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090310 Minefield/3.2a1pre


HTML format not getting copied and pasted properly in gmail compose window

1. Open http://www.w3schools.com/html/html_tables.asp in a seperate tab
2. Go to gmail.com and compose a new mail (with rich formatting enabled)
3. Select and copy the example HTML table in  http://www.w3schools.com/html/html_tables.asp
4. Paste it in the gmail compose window.
5. Minefield only pastes partial information

Works fine in Firefox 3.0.7

Reproducible: Always

Steps to Reproduce:
1. Open http://www.w3schools.com/html/html_tables.asp in a seperate tab
2. Go to gmail.com and compose a new mail (with rich formatting enabled)
3. Select and copy the example HTML table in  http://www.w3schools.com/html/html_tables.asp
4. Paste it in the gmail compose window.
5. Minefield only pastes partial information
Actual Results:  
Minefield only pastes partial information, does not copy the HTML table

Works fine in Firefox 3.0.7

Expected Results:  
Should be able to copy and pasted HTML tables in gmail compose window.
Version: unspecified → Trunk

Comment 1

9 years ago
Confirmed and annoyed. ( Windows XP, Gecko/20090310 Minefield/3.2a1pre) 

This bug can be reproduced if you copy texts for over one paragraph.

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3.1?
Keywords: regression, regressionwindow-wanted

Comment 2

9 years ago
Maybe a dupe of bug 480972
comment 1 matches regression range of bug 480972.
i'm not able to repro comment 0 though. the only thing that's not right is that the blinking caret is in the second last line instead the very last after pasting.
Does GMail use contentEditable? If so, this is a dupe ... marking, please re-open if that's the wrong assertion.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking-firefox3.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 480972
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.