Last Comment Bug 482759 - xulrunner xptcall MIPS patch
: xulrunner xptcall MIPS patch
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: Other Linux
: -- enhancement (vote)
: mozilla2.0b8
Assigned To: ZHANG Le
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 11:36 PDT by ZHANG Le
Modified: 2010-12-13 14:26 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
xulrunner-mips-o32.patch (17.19 KB, patch)
2009-03-11 11:37 PDT, ZHANG Le
no flags Details | Diff | Splinter Review
xulrunner-mips-n32.patch (24.16 KB, patch)
2009-03-11 11:37 PDT, ZHANG Le
no flags Details | Diff | Splinter Review
xulrunner-1.9.2_beta4-mips-n32.patch (24.16 KB, patch)
2010-02-27 18:46 PST, ZHANG Le
timeless: review+
Details | Diff | Splinter Review
patch for checkin NPOTB (24.86 KB, patch)
2010-12-12 04:17 PST, timeless
timeless: review+
Details | Diff | Splinter Review

Description ZHANG Le 2009-03-11 11:36:13 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009031017 Gentoo Firefox/3.0.7
Build Identifier: xulrunner 1.9.0.7

The old mips o32 ABI patch is not working anymore.
Thiemo Seufer made a patch, included in debian's mips firefox.
Unfortunately, he passed away 12.26 last year. So I submit this patch for him.

I myself made another patch for n32 ABI. This patch should be applied on top of the o32 patch.

Reproducible: Always
Comment 1 ZHANG Le 2009-03-11 11:37:22 PDT
Created attachment 366858 [details] [diff] [review]
xulrunner-mips-o32.patch
Comment 2 ZHANG Le 2009-03-11 11:37:51 PDT
Created attachment 366859 [details] [diff] [review]
xulrunner-mips-n32.patch
Comment 3 Nickolay_Ponomarev 2010-02-27 14:38:35 PST
Is it related to bug 258429's patch? It appears that you patched 1.9.0, and that patch landed for 1.9.1.

(Sorry this was ignored, it's best to follow https://developer.mozilla.org/En/Developer_Guide/How_to_Submit_a_Patch and cc the right people to avoid that.)
Comment 4 ZHANG Le 2010-02-27 18:46:43 PST
Created attachment 429370 [details] [diff] [review]
xulrunner-1.9.2_beta4-mips-n32.patch
Comment 5 ZHANG Le 2010-02-27 18:49:11 PST
o32 patch is already in upstream since 1.9.1.x. so i obsoleted it.
also i have updated n32 patch.
Comment 6 ZHANG Le 2010-02-27 18:50:30 PST
(In reply to comment #3)
> Is it related to bug 258429's patch? It appears that you patched 1.9.0, and
> that patch landed for 1.9.1.

bug 258429's patch contains o32 patch which i have made obsoleted.
Comment 7 Nickolay_Ponomarev 2010-02-28 02:28:20 PST
Comment on attachment 429370 [details] [diff] [review]
xulrunner-1.9.2_beta4-mips-n32.patch

Benjamin, could you take a look (or suggest someone else), since you reviewed the previous MIPS patch?
Comment 8 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-03-04 10:16:55 PST
Comment on attachment 429370 [details] [diff] [review]
xulrunner-1.9.2_beta4-mips-n32.patch

mh, could you look these over? I don't know MIPS at all, and you had bug 547656 which seems related.
Comment 9 Mike Hommey [:glandium] 2010-04-29 10:31:05 PDT
Comment on attachment 429370 [details] [diff] [review]
xulrunner-1.9.2_beta4-mips-n32.patch

Unfortunately, I know neither mips n32, nor mips assembly. And I don't have access to n32 mips machines either.
Comment 10 Mounir Lamouri (:mounir) 2010-09-15 21:47:31 PDT
The review has been requested months ago... Any news?
Comment 11 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2010-09-15 21:49:24 PDT
Currently there is no reviewer selected, and I don't know who an appropriate reviewer might be. Perhaps timeless would be willing?
Comment 12 Mounir Lamouri (:mounir) 2010-09-15 21:52:04 PDT
Oups, I've been confused with the review flag assigned to no-one. Let's try timeless then.
Comment 13 timeless 2010-10-10 02:20:56 PDT
i was on vacation last month. i've just reached this request. i'll look when i empty my mailbox (hopefully today).
Comment 14 ZHANG Le 2010-12-07 08:25:33 PST
So, any progress? Thanks!
Comment 15 timeless 2010-12-07 09:11:21 PST
Comment on attachment 429370 [details] [diff] [review]
xulrunner-1.9.2_beta4-mips-n32.patch

sorry, this indeed fell beneath my radar (not technically off, just not quite at the top).


+ * available which coorespond to the first 7 parameters of the

correspond


+#define PARAM_BUFFER_COUNT		16
+#define PARAM_GPR_COUNT			7
+#define PARAM_FPR_COUNT			7

please don't use tabs in .c/.cpp/.h, they should only be used in makefiles...

let's get this landed, very sorry about the delay
Comment 16 timeless 2010-12-12 04:17:53 PST
Created attachment 497133 [details] [diff] [review]
patch for checkin NPOTB

ok, this is for a port it should be able to land as NPOTB w/o requiring any approvals. I've addressed my comments.
Comment 17 Dão Gottwald [:dao] 2010-12-13 14:26:59 PST
http://hg.mozilla.org/mozilla-central/rev/269c205a438b

Note You need to log in before you can comment on or make changes to this bug.