[HTML5] Use method inlining in the HTML5 parser

RESOLVED DUPLICATE of bug 1358037

Status

()

Core
HTML: Parser
P4
normal
RESOLVED DUPLICATE of bug 1358037
9 years ago
10 months ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Other Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Currently, the Java to C++ translator generates method bodies in .cpp and doesn't mark methods 'inline' in C++.

Need to make the translator support C++ 'inline' method generation when a Java method has been annotated with @Inline and then need to mark methods that would benefit from inlining with @Inline.
(Reporter)

Updated

9 years ago
Assignee: nobody → hsivonen
(Reporter)

Updated

9 years ago
Priority: -- → P4
(Reporter)

Comment 1

9 years ago
Made the translator support @Inline but perf measurements are needed for deciding which methods really should be inlined.
(Reporter)

Updated

9 years ago
Assignee: hsivonen → nobody
(Reporter)

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358037
You need to log in before you can comment on or make changes to this bug.