If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Very small images are replaced with filename

VERIFIED DUPLICATE of bug 41924

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 41924
17 years ago
17 years ago

People

(Reporter: Martin Vollrathson, Assigned: clayton)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m17) Gecko/20000807
BuildID:    2000080712

Very small images are replaced with their filename.

Reproducible: Always
Steps to Reproduce:
1. Go to Nvidia's website.
2. Look between the NVIDIA logo and the "Company" button.


Actual Results:  The text "clearpixel" offsets the page, making it look weird.
"clearpixel.gif" is the name of the image file.

Expected Results:  The contents of clearpixel.gif should be visible.

The same thing can be observed on http://www.dagenstv.com/. The image in this
case is called 1x1blank.gif.

Comment 1

17 years ago
Confirmed on Linux 2000-08-09-10.  The images are not 404s.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

17 years ago
*** Bug 48394 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: nsbeta3

Comment 3

17 years ago
*** Bug 48389 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Per its dups, this might only occur with 1x1 px images.
(Reporter)

Comment 5

17 years ago
It appears as this wasn't a bug after all. I took a closer look and found that
both the websites where this occur have errors in the source code sending
Mozilla to look for images that don't exist. Netscape 4 and IE don't replace the
image with it's alt or filename when they can't find it. Therefor it looks ok
when these pages are viewed using NN or IE.
(Reporter)

Comment 6

17 years ago
I checked the duplicate bugs too. They have equal errors (404) in their source code.

Comment 7

17 years ago
A more dramatic example is found at http://www.ronssmokeshop.com
Marking invalid per the comment "This wasn't a bug after all" and "I checked the
duplicate bugs too. They have equal errors (404) in their source code."
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 9

17 years ago
Invalid? It looks like a dup of assigned bug 42474.
Ok, so I was lazy, this is really...
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
...a dup of 41924.

*** This bug has been marked as a duplicate of 41924 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
verified dup of mostfreq bug 41924 "Change how layout handles broken images (alt
text)"
Status: RESOLVED → VERIFIED

Comment 13

17 years ago
The resolution is incorrect.  The images are NOT 404.  They are 49-byte GIFs and
I can see that they are being received by examining tcpdump and my squid logs.
The bug is that 1x1 transparent gifs are replaced with their basename.  Reopening.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 14

17 years ago
*** Bug 48509 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 48509 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Yes, I'm not sure that they'll all broken images either.  No need to be hasty 
in marking bugs as dups or invalid...

Comment 17

17 years ago
at nvidia site the image that comes through as text "clearpixel" is called from
 /clearpixel.gif and it is a 404. An identically named gif is called twice from
another dir there,
 /Home.nfs/clearpixel.gif, and those occurances of the image does now show the
bug. (The word "clearpixel" is only seen once on nvidia page.)

at the url in bug 48394 http://www.beenz.com/fr/home.ihtml
the image <IMG height=5 src="../fr/registration/terms_standard_files/blnk.gif">
is a 404
So it *is* a dup of 41924, then? I'll let someone else mark it as such...

Comment 19

17 years ago
Would be interesting to see a working testcase. I wasn't able to make one:

 I made a 1x1 transparent gif, added in a wepage, and the name of the gif did
not display as text.

The real sites i've dug in till now boil down to 404's due to missing gif's /
error in path syntax.

Comment 20

17 years ago
Y'all are right and I am wrong.  The page at dagenstv.com has a mixture of 404's
(common/1x1blank.gif) and 200's (common/images/1x1blank.gif), which I mistakenly
thought were all correct.  The former resolution was in fact correct.  Spam off.

*** This bug has been marked as a duplicate of 41924 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
like i said ;-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.