Unable to Zoom using mouse wheel scroll on VIDEO element

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: BijuMailList, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
wanted1.9.2 +
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Unable to Zoom using mouse wheel scroll on VIDEO element

Step:-
(pre-condition: ensure full-zoom is active)
1. goto http://www.double.co.nz/video_test/test5.html
2. wait video to load the initial screen
3. bring mouse over the video element
4. press ctrl and do mouse wheel roll


Result:-
Nothing happen

Expected:-
video should do Zoom/Unzoom


PS: No sure this is the right component, please reclassify if needed.
Work around, bring mouse on top non-VIDEO area, then mouse wheel works
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Justin, could this be your controls?
Flags: wanted1.9.1? → wanted1.9.1+
(Reporter)

Updated

10 years ago
Blocks: 483730
(Reporter)

Updated

10 years ago
No longer blocks: 483730
Seems to work fine, if only you place your mouse outside the video :)
Is this bug also meant for e.g. the flash object here: http://blog.ppcproz.com/2009/03/what-is-google-ad-auction.html
Because the behavior is the same: object is zoomed, but only if the mouse is not on the object.
I can reproduce this on my Linux box, and it still happens if I comment out the controls' -moz-binding from html.css. Maybe this is a generic problem with native anonymous content?

Control-mousewheel also fails to zoom the page when the pointer is over some form controls, like buttons, checkboxes, and selects.

Comment 5

10 years ago
related to Bug 483136 ?
I can reproduce this on OS X, but if I use the video's context menu to hide the controls, Ctrl+Command mouse zooming works.
Flags: wanted1.9.2? → wanted1.9.2+
Duplicate of this bug: 541161
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: Trunk → unspecified
This WFM on Windows 10 Nightly 2015-05-04.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.