9 dom-level1-core and 4 dom-level2-html Mochitests run fine(?) but need to check/report success(/failure?)

VERIFIED FIXED in mozilla14

Status

()

Core
DOM: Core & HTML
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 1 bug)

Trunk
mozilla14
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox11 wontfix, firefox12 wontfix, firefox13 wontfix, firefox-esr10 wontfix)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
{
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237366670.1237376580.14560.gz&fulltext=1
Linux mozilla-central unit test on 2009/03/18 01:57:50
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237366174.1237371300.5105.gz&fulltext=1
OS X 10.5.2 mozilla-central unit test on 2009/03/18 01:49:34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237364751.1237377089.15377.gz&fulltext=1
WINNT 5.2 mozilla-central unit test on 2009/03/18 01:25:51

*** 34178 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_elementreplaceattributewithself.html...
*** 34180 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_elementreplaceexistingattribute.html...
}

(I noticed this on my Windows SeaMonkey/1.9.2 build...)

The 12 others are:
{
34676 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_elementreplaceattributewithself.html...
34703 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_entitiesremovenameditem1.html...
34706 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_entitiessetnameditem1.html...
35139 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_nodevalue07.html...
35142 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_nodevalue08.html...
35145 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_notationsremovenameditem1.html...
35148 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_notationssetnameditem1.html...
35507 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_nodelistindexequalzero.html...

37381 INFO Running /tests/dom/tests/mochitest/dom-level2-html/test_HTMLDocument18.html...
37384 INFO Running /tests/dom/tests/mochitest/dom-level2-html/test_HTMLDocument19.html...
37387 INFO Running /tests/dom/tests/mochitest/dom-level2-html/test_HTMLDocument20.html...
37390 INFO Running /tests/dom/tests/mochitest/dom-level2-html/test_HTMLDocument21.html...
}
(Assignee)

Updated

8 years ago
Blocks: 483555
(Assignee)

Updated

8 years ago
Summary: 8 dom-level1-core and 4 dom-level2-html Mochitests run fine(?) but need to check/report success(/failure?) → 9 dom-level1-core and 4 dom-level2-html Mochitests run fine(?) but need to check/report success(/failure?)
(Assignee)

Comment 1

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242092605.1242096280.17513.gz&fulltext=1
OS X 10.5.2 mozilla-central unit test on 2009/05/11 18:43:25
(Assignee)

Comment 2

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1242134886.1242139285.14399.gz&fulltext=1
WINNT 5.2 mozilla-1.9.1 unit test on 2009/05/12 06:28:06
(Assignee)

Updated

8 years ago
No longer blocks: 483407
Depends on: 483407
(Assignee)

Updated

8 years ago
No longer blocks: 483555
(Assignee)

Updated

5 years ago
Duplicate of this bug: 736884
(Assignee)

Updated

5 years ago
Blocks: 735805
(Assignee)

Comment 4

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10199321&tree=Firefox&full=1
Rev3 Fedora 12 mozilla-central debug test mochitests-3/5 on 2012-03-19 19:40:48 PDT for push b972b89518c3
{
1777 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_elementreplaceattributewithself.html

1778 INFO TEST-END | /tests/dom/tests/mochitest/dom-level1-core/test_elementreplaceattributewithself.html | finished in 640ms
}

*****

Ftr, when running this test alone:

[Mozilla/5.0 (Windows NT 5.0; rv:13.0a1) Gecko/20120201 Firefox/13.0a1 SeaMonkey/2.10a1] (nightly, 2012-02-01-00-30-09-comm-central-trunk)
{
Error: parentRunner is null
Source File: http://mochi.test:8888/tests/dom/tests/mochitest/dom-level1-core/DOMTestCase.js
Line: 648
}

That is a separate bug, but noting it here ftb.
(Assignee)

Updated

5 years ago
Assignee: nobody → sgautherie.bz
Target Milestone: --- → mozilla14
(Assignee)

Comment 5

5 years ago
Created attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

> Error: parentRunner is null
> 
> That is a separate bug, but noting it here ftb.

Actually, that is not as separate as I thought initially...

I don't know why it was added at the time,
but it seems unneeded (to say the least) nowadays.
Attachment #607478 - Flags: review?(sayrer)
(Assignee)

Comment 6

5 years ago
Created attachment 607514 [details] [diff] [review]
(Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks
[Checked in: Comment 12]

I tried to be both minimalist and consistent.
Attachment #607514 - Flags: review?(sayrer)
(Assignee)

Comment 7

5 years ago
Comment on attachment 607514 [details] [diff] [review]
(Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks
[Checked in: Comment 12]

Whoever reviews this/these first.
Attachment #607514 - Flags: review?(bzbarsky)

Comment 8

5 years ago
Try run for e67e54ee6782 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=e67e54ee6782
Results (out of 98 total builds):
    success: 90
    warnings: 8
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-e67e54ee6782
(Assignee)

Comment 9

5 years ago
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

(In reply to Mozilla RelEng Bot from comment #8)
>     https://tbpl.mozilla.org/?tree=Try&rev=e67e54ee6782

Succeeded.
Comment on attachment 607514 [details] [diff] [review]
(Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks
[Checked in: Comment 12]

r=me
Attachment #607514 - Flags: review?(bzbarsky) → review+

Comment 11

5 years ago
Try run for b5edde2abb07 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=b5edde2abb07
Results (out of 108 total builds):
    exception: 1
    success: 95
    warnings: 12
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-b5edde2abb07
(Assignee)

Comment 12

5 years ago
Comment on attachment 607514 [details] [diff] [review]
(Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks
[Checked in: Comment 12]

https://hg.mozilla.org/mozilla-central/rev/866ef7425e08
Attachment #607514 - Attachment description: (Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks → (Bv1) dom-level*-*/*: Work around tests that report no SimpleTest checks [Checked in: Comment 12]
Attachment #607514 - Flags: review?(sayrer)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Flags: in-testsuite+

Comment 13

5 years ago
Try run for e3c5c83f2afb is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=e3c5c83f2afb
Results (out of 119 total builds):
    exception: 3
    success: 90
    warnings: 14
    failure: 1
    other: 11
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-e3c5c83f2afb
 Timed out after 12 hours without completing.
(Assignee)

Comment 14

5 years ago
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

Whoever reviews this first.
Attachment #607478 - Flags: review?(bzbarsky)
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

I have no idea what this code is doing; someone else should review this.
Attachment #607478 - Flags: review?(bzbarsky)
(Assignee)

Updated

5 years ago
Attachment #607478 - Flags: review?(rcampbell)
(Assignee)

Updated

5 years ago
Blocks: 483555
No longer depends on: 483407
(Assignee)

Comment 16

5 years ago
With
(In reply to Alex Keybl [:akeybl] from bug 735805 comment #77)
> (the above includes blanket approval for the other test fixes for Aurora 13)
status-firefox-esr10: --- → affected
status-firefox11: --- → wontfix
status-firefox12: --- → affected
status-firefox13: --- → affected
Keywords: checkin-needed
Whiteboard: [c-n: 866ef7425e08 to m-a]
Attachment #607478 - Flags: review?(sayrer)
Attachment #607478 - Flags: review?(rcampbell)
Attachment #607478 - Flags: review+
(Assignee)

Comment 17

5 years ago
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

https://hg.mozilla.org/mozilla-central/rev/273173a592dc
Attachment #607478 - Attachment description: (Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult() → (Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult() [Checked in: Comment 17]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Depends on: 739927
if this is going to backport bug 739927 to Aurora, we should really not push these to Aurora. It's painful enough to star central now to bring that pain to another tree.
clearing until clarified the benefit vs the obvious downside.
Keywords: checkin-needed
Whiteboard: [c-n: 866ef7425e08 to m-a]
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

The overrides were using todoTests objects that define special test exclusions. SimpleTest doesn't know about these, and we ended up causing Bug 739927. We should backout this imo, until those specific instances are fixed.  Before making impossible to star m3 failures, not after.
Attachment #607478 - Flags: review-
Backed out for comment 20:
https://hg.mozilla.org/mozilla-central/rev/f0a104d6cc36
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 22

5 years ago
Comment on attachment 607478 [details] [diff] [review]
(Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult()
[Backed out: Comment 21]

Let's move this part to bug 739927.
Attachment #607478 - Attachment description: (Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult() [Checked in: Comment 17] → (Av1) dom-level*-*/DOMTestCase.js: Remove sayrer's override of SimpleTest._logResult() [Backed out: Comment 21]
Attachment #607478 - Attachment is obsolete: true
(Assignee)

Comment 23

5 years ago
(In reply to Marco Bonardo [:mak] from comment #18)
> if this is going to backport bug 739927 to Aurora

(In reply to Marco Bonardo [:mak] from comment #19)
> clearing until clarified the benefit vs the obvious downside.

No, that is the other part.


(In reply to Marco Bonardo [:mak] from comment #20)

> The overrides were using todoTests objects that define special test
> exclusions. SimpleTest doesn't know about these, and we ended up causing Bug
> 739927.

I understood that but missed to notice bug 739927, because these "failures" are actually morphed into "todos" wrt result counts (in markTodos()) :-|

> We should backout this imo, until those specific instances are
> fixed.  Before making impossible to star m3 failures, not after.

Agreed.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [c-n: 866ef7425e08 to m-a]
(Assignee)

Updated

5 years ago
No longer blocks: 483555
(Assignee)

Updated

5 years ago
Blocks: 741091
(Assignee)

Comment 24

5 years ago
V.Fixed, as still "succeeding" after bug 735805 landing.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 25

5 years ago
Missed Aurora-13 :-| Giving up on older branches.
status-firefox-esr10: affected → wontfix
status-firefox12: affected → wontfix
status-firefox13: affected → wontfix
Keywords: checkin-needed
Whiteboard: [c-n: 866ef7425e08 to m-a]
You need to log in before you can comment on or make changes to this bug.