Various tests in dom/tests/mochitest/dom-level* don't test anything

RESOLVED DUPLICATE of bug 483992

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 483992
6 years ago
6 years ago

People

(Reporter: ayg, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Problem files:

dom/tests/mochitest/dom-level1-core/test_elementreplaceattributewithself.html
dom/tests/mochitest/dom-level1-core/test_hc_elementreplaceattributewithself.html
dom/tests/mochitest/dom-level1-core/test_hc_entitiesremovenameditem1.html
dom/tests/mochitest/dom-level1-core/test_hc_entitiessetnameditem1.html
dom/tests/mochitest/dom-level1-core/test_hc_nodevalue07.html
dom/tests/mochitest/dom-level1-core/test_hc_nodevalue08.html
dom/tests/mochitest/dom-level1-core/test_hc_notationsremovenameditem1.html
dom/tests/mochitest/dom-level1-core/test_hc_notationssetnameditem1.html
dom/tests/mochitest/dom-level1-core/test_nodelistindexequalzero.html
dom/tests/mochitest/dom-level2-core/test_createDocument03.html
dom/tests/mochitest/dom-level2-html/test_HTMLDocument18.html
dom/tests/mochitest/dom-level2-html/test_HTMLDocument19.html
dom/tests/mochitest/dom-level2-html/test_HTMLDocument20.html
dom/tests/mochitest/dom-level2-html/test_HTMLDocument21.html

According to <https://tbpl.mozilla.org/php/getParsedLog.php?id=10127605&tree=Try>, none of these actually run any tests.  It seems like there's probably some exception being thrown internally before anything interesting happens, but being caught and ignored by an overly broad try/catch.  At least that's what I'd guess from looking at the first couple.  Bug 735805 will add todo()s to these.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483992
No longer blocks: 735805
You need to log in before you can comment on or make changes to this bug.