Unknown content type dialog cut off

VERIFIED FIXED in Firefox 3.6a1

Status

()

--
minor
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: wladow, Assigned: rstrong)

Tracking

({regression, verified1.9.1})

Trunk
Firefox 3.6a1
x86
Windows Vista
regression, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Created attachment 368036 [details]
vista screenshot - 3.5b4 vs 3.6a1

Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre

Localized Unknown content type dialog is cut off on trunk and can't be resized, neither by dragging the mouse nor in the locale files. Sanitize dialog is cut off too, but localizers can alter its width at least in locale files. This doesn't affect branch builds.

Maybe this issue has something to do with Bug 390734 ? Just guessing...
Keywords: regressionwindow-wanted
Regression window:

2009-03-11-05 (dialog ok, no native groupbox theming)
2009-03-12-05 (cut off, with native theming)

so it's the time range when Bug 390734 landed...
Keywords: regressionwindow-wanted
Created attachment 368210 [details] [diff] [review]
patch rev1

This dialog is a tad fragile from what I can see. Instead of rewriting it I'm going with a dirt simple fix that will only affect Windows.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #368210 - Flags: review?(mconnor)
Created attachment 368211 [details]
screenshots

You can see in the screenshots that even though the window has a style width of 34em before and after Bug 390734 landed the window's width is different. You can also see that with 36em the width is almost exactly the same as it was before Bug 390734 landed.
Comment on attachment 368210 [details] [diff] [review]
patch rev1

Dao, could you review this?
Hm, so window.sizeToContent() is broken? We should definitely have a bug on that.
What happens if you just remove style="width: 34em;"?
Attachment #368210 - Flags: review?(dao) → review-
Comment on attachment 368210 [details] [diff] [review]
patch rev1

So this fixes it for random locale X, but will it also work for random locale Y? Probably OK as an interim solution, but r- for now, as I think removing the style altogether works; please re-request if it doesn't.
(In reply to comment #7)
> (From update of attachment 368210 [details] [diff] [review])
> So this fixes it for random locale X, but will it also work for random locale
> Y? Probably OK as an interim solution, but r- for now, as I think removing the
> style altogether works; please re-request if it doesn't.
I agree but I am pretty sure that is a pre-existing bug and I'm not willing to localize the width to fix this... I think it might be best to localize it or even better fix up the dialog so it doesn't need the width at all but it appears that the width was put there to keep the dialog from resizing whenever the checkbox was checked which resizes it using sizeToContent
(In reply to comment #8)
> (In reply to comment #7)
> > (From update of attachment 368210 [details] [diff] [review] [details])
> > So this fixes it for random locale X, but will it also work for random locale
> > Y? Probably OK as an interim solution, but r- for now, as I think removing the
> > style altogether works; please re-request if it doesn't.
> I agree but I am pretty sure that is a pre-existing bug and I'm not willing to
> localize the width to fix this... I think it might be best to localize it or
> even better fix up the dialog so it doesn't need the width at all but it
> appears that the width was put there to keep the dialog from resizing whenever
> the checkbox was checked which resizes it using sizeToContent
specifically, resizing the width whenever the checkbox was checked which resizes it using sizeToContent
Comment on attachment 368210 [details] [diff] [review]
patch rev1

Re-requesting because I believe that any locale that is broken is likely already broken and we can take care of this in a general cleanup bug for this ui since it is in need of some love
Attachment #368210 - Flags: review?(dao)
Attachment #368210 - Flags: review?(dao)
Attachment #368210 - Flags: review-
Attachment #368210 - Flags: review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/6d088dfd05b1
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Comment on attachment 368210 [details] [diff] [review]
patch rev1

Drivers, I'm going to want this when I land bug 390734
Attachment #368210 - Flags: review?(mconnor) → approval1.9.1?
Comment on attachment 368210 [details] [diff] [review]
patch rev1

a191=beltzner
Attachment #368210 - Flags: approval1.9.1? → approval1.9.1+
Verified fixed with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre ID:20090318052249

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090322 Shiretoko/3.5b4pre ID:20090322140038
Severity: normal → minor
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
Target Milestone: --- → Firefox 3.6a1
Does bug 522063 relate?
I would think so at least in part.
You need to log in before you can comment on or make changes to this bug.