Reply To All changes multiple 'To:' recipients from original mail to 'CC:' in reply mail

RESOLVED DUPLICATE of bug 250187

Status

--
enhancement
RESOLVED DUPLICATE of bug 250187
10 years ago
10 years ago

People

(Reporter: gweedoh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: version 2.0.0.19 (20081209)

In ThunderBird, when a message is received marked 'To:' several recipients, a Reply To All moves all of these recipients to 'CC:' with the exception of the original sender who is marked as a 'To:' recipient.

I'm part of a large group of people that brainstorms via email. Many people in this list receive dozens of e-mails a day and filter them based on if we're listed as a To: recipient or a CC: recipient. Since CC is assumed to be a less direct communication, they are given a lower priority and may be overlooked by the recipient.

I would like to be able to set an option where Reply To All keeps the original recipient delivery structure (i.e. whoever was 'To:' remains 'To:' and whoever was a 'CC:', 'BCC;', etc remains so in the Reply To All).

Reproducible: Always

Steps to Reproduce:
Reply To All on a message sent 'To:' multiple recipients.
Actual Results:  
All recipients (except the original sender) marked 'To:' in the original email are marked as 'CC:' in the reply message.

Expected Results:  
All recipients marked 'To:' in the original email should be marked 'To:' in the reply email.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250187
You need to log in before you can comment on or make changes to this bug.