mochitest-plain: test_jQuery.html intermittent test failures: stop() - several in queue, etc.

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
11 years ago
5 months ago

People

(Reporter: mossop, Assigned: cmtalbert)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments)

Failures in jQuery not caused by the landing:

*** 30099 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - An animation occurred 0px 0px
*** 30100 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - Stop didn't reset the animation 0px 0px
*** 30102 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue) - An animation occurred 0px 0px
*** 30103 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue) - Stop didn't reset the animation 0px 0px

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1237906999.1237911474.4952.gz&fulltext=1
Whiteboard: [orange]
I'll take this one and see if I can track it down.
Assignee: nobody → ctalbert
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1241518848.1241524376.32324.gz
Linux mozilla-1.9.1 unit test on 2009/05/05 03:20:48
Flags: wanted1.9.1?
Summary: jQuery intermittent test failures → mochitest-plain: test_jQuery.html intermittent test failures
Version: 1.9.1 Branch → Trunk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248262310.1248270271.27484.gz
Linux mozilla-central unit test on 2009/07/22 04:31:50  
31245 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - Stop() reset the animation expected: 200 actual: 1
31246 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248448421.1248456741.18782.gz&fulltext=1
Linux mozilla-central unit test on 2009/07/24 08:13:41

Clint, I know it was a few months ago when you said you'd take a look, but any chance you can try again - this is now happening every couple days, it seems.
(In reply to comment #8)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248448421.1248456741.18782.gz&fulltext=1
> Linux mozilla-central unit test on 2009/07/24 08:13:41
> 
> Clint, I know it was a few months ago when you said you'd take a look, but any
> chance you can try again - this is now happening every couple days, it seems.

Yeah sorry.  Taking a look at this today.
Ugh.  This is a real mess.  Many of these fail here: http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/ajax/jquery/test/unit/fx.js#92

And it is always because there are less things in the queue than jquery expects.  That might be due to the faster processing we have now, this animate/timeout setup might be based on an expectation of a slower browser.  

However, we also have entire test timeouts, and in running the jquery suite itself over and over last night I came up with two additional failures:

= mac Laptop (546 runs)=
run4.log:326 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | Test timed out.

= Windows 7 Machine (312 runs)=
(no failures),

= Linux VM (860 runs) =
run0.log:924 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - Stop() reset the animation expected: 200 actual: 1
run0.log:925 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2

= Linux Machine (1228 runs)=
* no fails

While there is a timeout failure there, it's not timing out in the same place as the timeout reported in comment 5.

Looking at the jquery source, this looks like 1.2.2.  The current jquery library is at 1.3.2, which has a release zip with source and tests:
http://jqueryjs.googlecode.com/files/jquery-1.3.2-release.zip

Looking closely at those tests, particularly the ones that are giving us so many headaches in the fx module, I see that in the 1.3.2 version of the test suite, they commented out many of these assertions because they were "flaky".

I see two ways to proceed here:
1. Believe the Jquery team knows their product and comment out the same assertions as being flaky
2. Upgrade to the latest jquery source and tests: version 1.3.2 (which also has the same effect as commenting out those assertions but takes a whole bunch of extra changes too).
3. Delve deeper into the product to try and understand when that assertion began to fail. The best way to do that would be to make a minimized test case of the failure and bisect on it, but I can't guarantee that such a test case will fail. :/

I'm open to opinions.  I'm thinking of commenting out the failing assertions and replacing them with some logging statements to try and understand what is happening here. (Essentially choice 1).

Also CC'ing jresig to see if he has any other details about why these assertions were deemed flaky that might shed some light on the problem.
While trying to get the jquery test system to print useful debug information, I noticed that the test is throwing an assert here: http://mxr.mozilla.org/mozilla-central/source/docshell/shistory/src/nsSHEntry.cpp#598 ( ASSERTION: Adding child where we already have a child?  This will likely misbehave: 'Error', file /Users/clint/code/mozcentral/src/docshell/shistory/src/nsSHEntry.cpp, line 598).

I saw many of these assertions while running the jquery suite in debug, and if you just run the test that fails most often for us, it does *not* assert.  However, adding even one more test in makes the assertion appear.  That code hasn't changed since we moved it to Hg though, so I think this is a red herring.  I'm bothering to mention it because I'm wondering just how tripping this assertion might be expected to "misbehave".  It's not all that clear from a quick look at the code.

You can use this attachment to run just a single part of the jquery test suite that makes this assert happen consistently.

Test cmd line: python runtests.py --autorun --close-when-done --test-path=dom/tests/mochitest/ajax/jquery --log-file=results.log 2>&1|tee output.log

Still working on better logging/commenting out assertion for better running test case.
WINNT 5.2 mozilla-central unit test on 2009/07/28 13:45:44  
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248813944.1248820337.11437.gz

31296 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - Stop() reset the animation expected: 200 actual: 1
31297 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2
This is a patch that merges in the pieces of jquery fx test version 1.3.2 that comment out some of the specific assertions that are failing for us.  In jquery 1.3.2's test suite, these assertions are marked as being flaky. However, more research has uncovered that these are active assertions used in the jquery trunk test suite.  I'm going to follow up with the jquery folks and ask if they've determined the cause for the flakiness of this code.

In the meantime while I'm doing that, we might as well comment these out (as was done in the jquery 1.3.2 release) and solve most of the cases here with jquery.  I don't expect this to solve the issue with the timeout of the entire jquery test suite -- I don't know what caused that, but it doesn't seem to be too common.  I recommend we take this as a stop gap, and then figure out what to do next.
Attachment #391760 - Flags: review?(johnath)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249096419.1249098469.5334.gz

30043 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - Stop() reset the animation expected: 200 actual: 1
30044 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249100262.1249101935.10107.gz

30020 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
30023 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - The next animation continued expected: 2 actual: 0
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249137747.1249140228.15423.gz

Error 0 (Unknown error: 0).30058 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249145344.1249147449.763.gz
Linux mozilla-central test mochitests on 2009/08/01 09:49:04  

30045 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - Stop() reset the animation expected: 200 actual: 1
30046 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop(clearQueue, gotoEnd) - The next animation continued expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249162139.1249166773.16568.gz

.../test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
.../test_jQuery.html | fx module: stop() - several in queue - The next animation continued expected: 2 actual: 0
Attachment #391760 - Flags: review?(johnath) → review?(jresig)
Comment on attachment 391760 [details] [diff] [review]
Patch to stop 90% of the cases

I'm not really the right one to review these changes, since I don't work on the Mozilla code these tests exercise, nor the tests themselves. On the other hand, it looks like these are all simple merges over from the jquery tests to calm down flakiness, which counts as a test-only bustage fix to me, and this is a frequent orange.

I think we should ask jresig if he sees any danger in making these changes, but if we can't get ahold of him near-term, I also think it would be legitimate for this to get post-hoc review - land now to clean up the orange, but don't resolve the bug until we know the changes were legitimate.

We should probably file a follow-up to pick up the updated jquery test suite wholesale, since it's clear they are making test-stability changes.
(In reply to comment #20)
> I think we should ask jresig if he sees any danger in making these changes, but
> if we can't get ahold of him near-term, I also think it would be legitimate for
> this to get post-hoc review - land now to clean up the orange, but don't
> resolve the bug until we know the changes were legitimate.

I also followed up about this issue on the jquery discussion list, and Jresig responded there.  I'll post my message and his response.
=== My message ===
Hi,

I'm trying to track down a problem that we are having with a 1.2.2
version of the Jquery library and test suite that we run in Mozilla's
automated Mochitest system (bug 484994 [1]).  The problems we seem to
have most often are that the tests "stop(clearQueue, gotoEnd)" and
"stop() - several in queue" in the fx unit test module are very
flaky.

I downloaded the 1.3.2 release and I'm planning to upgrade our system
to that (just a good idea in general).  And I noticed that the
assertions in these tests were commented out in 1.3.2 for being
"flaky" (and they still are in the current trunk code).

I wanted to know if you knew why these were flaky, and if they were
flaky across all browsers or if this is something I should be
concerned about digging into for Firefox specifically.

Thanks very much for your help.

Clint

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=484994
		
John Resig   	
View profile  
	 More options Jul 31, 6:43 am
From: John Resig <jere...@gmail.com>
Date: Fri, 31 Jul 2009 09:43:04 -0400
Local: Fri, Jul 31 2009 6:43 am
Subject: Re: [jquery-dev] JQuery Fx Unit Test
Reply | Reply to author | Forward | Print | Individual message | Show original | Report this message | Find messages by this author

I've looked into this issue a bit and, so far, the only thing I've been able
to determine is that sometimes when a browser is under heavy load timers
start to work incorrectly (I've noticed this much more so in Firefox, and to
a lesser degree in Safari). Sometimes one timer will fire after another,
even though it shouldn't occur (e.g. one timer is started with a timeout of
100ms, another with 2000ms - but the second one finishes first).

We recently commented out another batch of FX tests that were having a
similar problem to the one that you noted (for the upcoming 1.3.3 release).

If there was some guarantee that timers would always execute in the same
order in which they were called (relative to their timer delay) then that
would probably remove the issues we're seeing.

However, on a whole, we're just backing off from testing multiple,
simultaneous, timers since it's just too hard to quantify.

--John 

> We should probably file a follow-up to pick up the updated jquery test suite
> wholesale, since it's clear they are making test-stability changes.
True.  I filed bug 508139 for this.  I also replied to John's post above (on the jquery mailing list) and asked for an ETA on jquery 1.3.3.

I think given the number of times we are hitting this we should check this in now and get jresig's post facto review.
(In reply to comment #20)
> (From update of attachment 391760 [details] [diff] [review])
> it looks like these are all simple merges over from the jquery tests to calm
> down flakiness, which counts as a test-only bustage fix to me, and this is a
> frequent orange.
Pushed to m-c: 03c031750aff

Leaving bug open for now...
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249927270.1249932666.25858.gz
> test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2

(Not sure if the push in comment 23 was supposed to fix this on m-c, but it apparently didn't.)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249955665.1249957434.5323.gz
WINNT 5.2 mozilla-central test mochitests on 2009/08/10 18:54:25  
30301 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250153331.1250156070.4539.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/08/13 01:48:51  
31782 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250155893.1250158416.29964.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/08/13 02:31:33  
31779 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250182257.1250185320.21382.gz
WINNT 5.2 mozilla-central test mochitests on 2009/08/13 09:50:57  
31732 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250201430.1250209464.675.gz
OS X 10.5.2 mozilla-central unit test on 2009/08/13 15:10:30
31778 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250501950.1250506988.31122.gz
OS X 10.5.2 mozilla-central unit test on 2009/08/17 02:39:10
32048 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250549861.1250552046.32294.gz
Linux mozilla-central test mochitests on 2009/08/17 15:57:41

... | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250626394.1250628315.22957.gz
WINNT 5.2 mozilla-central test mochitests on 2009/08/18 13:13:14

... | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251300019.1251302367.29066.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/08/26 08:20:19
32436 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251877456.1251879910.11187.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/09/02 00:44:16
32449 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
OS X 10.5.2 mozilla-central test mochitests
30035 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_wav_ended2.html | Expect at least one playing event
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251873463.1251875859.32366.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1252052652.1252054950.10235.gz
ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1252084652.1252087036.24229.gz&fulltext=1

Error 0 (Unknown error: 0).32465 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
97993 INFO Error: Unable to restore focus, expect failures and timeouts
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1252109452.1252113612.32604.gz
Linux mozilla-central test mochitests on 2009/09/04 17:10:52

... | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254398959.1254400950.31489.gz
Linux mozilla-central test opt mochitests on 2009/10/01 05:09:19

33224 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256502246.1256502875.29009.gz
Linux mozilla-central test debug mochitests-2/5 on 2009/10/25 13:24:06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256576757.1256578335.31481.gz
Linux mozilla-central test debug mochitests-2/5 on 2009/10/26 10:05:57  

1494 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256730158.1256731595.7883.gz
Linux mozilla-central test debug mochitests-2/5 on 2009/10/28 04:42:38  

1494 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257157984.1257159375.16039.gz
Linux mozilla-central test debug mochitests-2/5 on 2009/11/02 02:33:04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257189094.1257191314.3291.gz
WINNT 5.2 mozilla-central test debug mochitests-2/5 on 2009/11/02 11:11:34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257261043.1257262404.24161.gz
Linux mozilla-central test debug mochitests-2/5 on 2009/11/03 07:10:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257557494.1257559024.2638.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/06 17:31:34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257680489.1257681965.14476.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2009/11/08 03:41:29  
1499 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257783466.1257785993.25488.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/09 08:17:46  
1499 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257813978.1257816557.20713.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/09 16:46:18  
1499 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257893746.1257896117.25881.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/10 14:55:46
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257910903.1257913922.30238.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/10 19:41:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1258187353.1258191198.32376.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2009/11/14 00:29:13
s: moz2-darwin9-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258427997.1258430859.29509.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/16 19:19:57  
s: moz2-linux-slave06
1500 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259023942.1259025560.10311.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/23 16:52:22
s: moz2-linux-slave21
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259125590.1259126795.30878.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/11/24 21:06:30
s: moz2-linux-slave23
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259139153.1259140403.21456.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2009/11/25 00:52:33
"s: moz2-win32-slave16"
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259677047.1259678325.2798.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/01 06:17:27
s: moz2-linux-slave20
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260188882.1260190786.29206.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/07 04:28:02
s: moz2-linux-slave10
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
Summary: mochitest-plain: test_jQuery.html intermittent test failures → mochitest-plain: test_jQuery.html intermittent test failures: stop() - several in queue, etc.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260577967.1260579762.29771.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/11 16:32:47
s: moz2-linux-slave12
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260584961.1260586817.10918.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/11 18:29:21
s: moz2-linux-slave15
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260613305.1260615120.27966.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/12 02:21:45
s: moz2-linux-slave02
1513 ERROR TEST-UNEXPECTED-FAIL |
/tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260730825.1260732765.28222.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2009/12/13 11:00:25
s: win32-slave02
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260738486.1260740986.24739.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/13 13:08:06
s: moz2-linux-slave12
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260846447.1260847954.21314.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/14 19:07:27
s: moz2-linux-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1260862176.1260866675.31353.gz
Linux mozilla-1.9.2 test mochitests on 2009/12/14 23:29:36
s: moz2-linux-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260892595.1260894176.22129.gz#err0
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2009/12/15 07:56:35  
s: win32-slave31
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261155028.1261156276.12615.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/18 08:50:28
s: moz2-linux-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261177313.1261179743.17291.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/18 15:01:53
s: moz2-linux-slave01
1476 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261323464.1261325512.15468.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/20 07:37:44
s: moz2-linux-slave07
1476 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261392512.1261394359.23140.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/21 02:48:32
s: moz2-linux-slave18
1476 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261439945.1261442026.22911.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/21 15:59:05
s: moz2-linux-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261543829.1261545744.21633.gz
Linux mozilla-central debug test mochitests-2/5 on 2009/12/22 20:50:29
s: moz2-linux-slave24
WINNT 5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 05:00, finished 05:25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262091658.1262093045.1968.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262904192.1262906380.2224.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/01/07 14:43:12
s: win32-slave24
1513 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263837734.1263839652.24459.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263935227.1263937004.20771.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/01/19 13:07:07
s: bm-xserve16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1264102816.1264106335.30600.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2010/01/21 11:40:16
s: moz2-darwin9-slave13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264200646.1264204129.30008.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/01/22 14:50:46
s: moz2-linux-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264216868.1264218208.25483.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/01/22 19:21:08
s: bm-xserve18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265186388.1265188916.22597.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/02/03 00:39:48
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 16:50, finished 17:32


http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265763021.1265765485.16256.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265769218.1265772210.28235.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/09 18:33:38
s: moz2-darwin9-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265831079.1265833414.20767.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/10 11:44:39
s: moz2-darwin9-slave17
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265869326.1265871561.28317.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/10 22:22:06
s: moz2-darwin9-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265890039.1265892404.4808.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/11 04:07:19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265880700.1265883125.27538.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/11 01:31:40
s: moz2-darwin9-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265914139.1265916479.1727.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/11 10:48:59
s: moz2-darwin9-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265917966.1265920281.12271.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/11 11:52:46
s: moz2-darwin9-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265927934.1265930634.31959.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/11 14:38:54
s: moz2-darwin9-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266482207.1266484398.20346.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/18 00:36:47
s: moz2-darwin9-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266518245.1266520509.11314.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/18 10:37:25
s: moz2-darwin9-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266518245.1266520509.11314.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266587238.1266589627.29885.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/19 05:47:18  
s: moz2-darwin9-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266599763.1266602154.10366.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 09:16, finished 09:56
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266608473.1266610804.7571.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 11:41, finished 12:21
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 13:12, finished 13:57

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266613965.1266616599.26463.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 14:28, finished 15:10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266618531.1266620947.9431.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266699876.1266702145.1990.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/20 13:04:36
s: moz2-darwin9-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266871263.1266873953.17346.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/22 12:41:03
s: moz2-darwin9-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267204377.1267206644.15898.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/26 09:12:57
s: moz2-darwin9-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267306471.1267309128.1326.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/02/27 13:34:31
s: moz2-darwin9-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267615015.1267617380.17829.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/03 03:16:55
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268045529.1268047193.6963.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/08 02:52:09
s: win32-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268055645.1268057380.7662.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/08 05:40:45
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268333233.1268335294.14785.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/11 10:47:13
s: win32-slave35
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268523879.1268525659.26980.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 15:44:39
s: win32-slave35
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268602293.1268604882.19965.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/14 14:31:33
s: win32-slave17
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268821903.1268824736.4500.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/17 03:31:43
s: moz2-linux-slave41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268937913.1268939972.2309.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/18 11:45:13
s: win32-slave34

1578 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - An animation occurred 0px 0px
1579 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - Stop didn't reset the animation 0px 0px
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268940289.1268942641.10956.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/18 12:24:49
s: win32-slave34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269202367.1269204662.5815.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/21 13:12:47
s: moz2-darwin9-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269555344.1269557564.7012.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/25 15:15:44
s: moz2-darwin9-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269917981.1269920176.29515.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/29 19:59:41
s: moz2-darwin9-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269945566.1269947754.5873.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/30 03:39:26
s: moz2-darwin9-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269976443.1269978674.12828.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/30 12:14:03
s: win32-slave20
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269985818.1269988010.9500.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/30 14:50:18
s: moz2-darwin9-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270075991.1270077480.17290.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/31 15:53:11
s: win32-slave37
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270099574.1270101742.5705.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/31 22:26:14
s: moz2-darwin9-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270150846.1270154317.7704.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/04/01 12:40:46
s: win32-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270162509.1270164765.4653.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/04/01 15:55:09
s: moz2-darwin9-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270164485.1270166575.9301.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/04/01 16:28:05
s: win32-slave42
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270186423.1270188617.28902.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/04/01 22:33:43
s: moz2-darwin9-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270190080.1270192287.4124.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/04/01 23:34:40  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270193969.1270195932.12785.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/04/02 00:39:29  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270192135.1270194392.8794.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/04/02 00:08:55  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270217312.1270218770.29167.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/04/02 07:08:32
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/04/02 08:12:42
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270221162.1270223389.8982.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270226278.1270228554.24844.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 09:37, finished 10:16
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 10:06, finished 10:44

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270227985.1270230203.29462.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 12:04, finished 12:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270234309.1270236249.12924.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 [testfailed] Started 13:28, finished 13:59
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270240112.1270241882.27200.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270273565.1270275442.8806.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 on 2010/04/02 22:46:05
s: talos-r3-snow-008
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270327820.1270329691.20255.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 on 2010/04/03 13:50:20
s: talos-r3-snow-015
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270969494.1270972349.25917.gz
Linux comm-central-trunk debug test mochitests-2/5 on 2010/04/11 00:04:54
s: cb-seamonkey-linux-03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273812262.1273813912.2797.gzRev3 Fedora 12 mozilla-central debug test mochitests-2/5 on 2010/05/13 21:44:22

s: talos-r3-fed-032
1648 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
Hardware: x86 → All
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281231094.1281232603.3980.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 on 2010/08/07 18:31:34

s: talos-r3-snow-003
3643 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281235086.1281236806.23115.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 on 2010/08/07 19:38:06

s: talos-r3-snow-003
3641 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1281252572.1281254074.29064.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey debug test mochitests-2/5 on 2010/08/08 00:29:32

s: talos-r3-leopard-042
3638 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281462011.1281464338.20299.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/08/10 10:40:11

s: win32-slave32
3675 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281561029.1281563438.30712.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/08/11 14:10:29

s: win32-slave37
3710 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | fx module: stop() - several in queue - All 3 still in the queue expected: 3 actual: 2