TM: Gmail contacts list is empty

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
P1
major
VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Peter6, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 485889])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090324
Minefield/3.6a1pre ID:20090324130643

repro:
open FF
make sure content.jit is enabled (= default)
open gmail
click on the tab "contacts"

result:
an empty page opens

expected:
see the list of contacts

works with jit disabled

regression:
works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre)
Gecko/20090324 Minefield/3.6a1pre ID:20090324122534
broken in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre)
Gecko/20090324 Minefield/3.6a1pre ID:20090324130643
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fb5635f0d184&tochange=4a34c6235bb7

this may be a dupe of Bug 485625
(Reporter)

Updated

9 years ago
Flags: blocking1.9.2?

Comment 1

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090327 Minefield/3.6a1pre ID:20090327211924
javascript.options.jit.content;true
javascript.options.jit.chrome;false

Default has reported behaviour
Option exists in gmail to use "Older version" - behaviour is as expected and works (ie list of contacts is there)
works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090320 Minefield/3.6a1pre ID:20090320033632
http://hg.mozilla.org/tracemonkey/rev/4fc08ad56525
fails:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090321 Minefield/3.6a1pre ID:20090321032204
http://hg.mozilla.org/tracemonkey/rev/14b568cd9c43

=> range:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=4fc08ad56525&tochange=14b568cd9c43

from bug 485625: viewing picture on Picasa web album is also broken
Version: unspecified → Trunk
Duplicate of this bug: 485625
(Reporter)

Updated

9 years ago
OS: Windows XP → All
Hardware: x86 → All
Flags: blocking1.9.1?

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Comment 4

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090328 SeaMonkey/2.0b1pre ID:20090328001702

Since this is marked core and blocking 1.9.1, I must say that it WFM in the Seamonkey nightly builds. The Gmail contacts list is slow in appearing but it does appear, also the drop-down address list in Gmail composer is working. Have not tried Picasa!

Comment 5

9 years ago
re comment #4. I am using pre-release Java 6.14. I'll go back to 6.12 and see if it matters.
(Reporter)

Comment 6

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090327 Minefield/3.6a1pre ID:20090327061159

one more Gmail case:

repro:
create a new mail
type the name you want to send your mail to in the "To" field

result:
nothing, the list of suggested e-mail addresses does not appear.
This means you'll have to type the full e-mail address.

Comment 7

9 years ago
re comment #5. Of course we,re talking javascript here!!

Comment 8

9 years ago
Is it me, or does Gmail seem to load much faster with JIT off? And I noticed the dropdown contacts were broken last Thursday or so (the contacts list still worked) and then it broke even more and now nothing shows up with JIT enabled.
(Reporter)

Comment 9

9 years ago
Yeah, it appears quicker to me with jit off aswell.
Especially opening "all mail" is a lot faster

Comment 10

9 years ago
(In reply to comment #9)
> Yeah, it appears quicker to me with jit off aswell.
> Especially opening "all mail" is a lot faster

This is not the place to idly discuss performance problems. But do keep in mind that it's hard to A/B test GMail the way I think you guys are doing it, because you're encountering HTTP or server caching of the actions you're performing.
Where's a better place to talk about anomalies (even if they turn out to be not our bug)? Maybe in a new bug, true.

I hope bug 479110 (needs new patch) fixes any real worse-than-interpreter jit perf probs that might be manifesting.

But I welcome perf bug-sense news from gmail users who tend to key into real but sometimes small differences. Until we have a Tgmail automated perf test, I'll take such reports, here or in a new bug, and not banish them to a UFO groupzine or wherever ;-).

/be

Updated

9 years ago
Priority: -- → P1

Comment 12

9 years ago
this looks fixed to me on TM trunk

Comment 13

9 years ago
If we fixed this I think we should identify the patch that did it. This was a major correctness bug.

Comment 14

9 years ago
Now fixed on 03-31-2009 Minefield nightly. Broken on 03-30-2009 Minefield nightly.

Comment 15

9 years ago
Still want the regression window for this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

9 years ago
(In reply to comment #15)
> Still want the regression window for this.
see last lines of comment #0, those are 2 hourly builds right after each other.
(In reply to comment #13)
> If we fixed this I think we should identify the patch that did it. This was a
> major correctness bug.

We also need a test - as far as I know we have no test coverage for this issue and it's high visibility.
(Reporter)

Comment 18

9 years ago
"progressionwindow" to find what fixed it:
fails in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090331 Minefield/3.6a1pre ID:20090331022211
works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090331 Minefield/3.6a1pre ID:20090331044608

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a45593185b3a&tochange=ca4d8bb54e7f

in between the tracemonkey merges you'd get:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=47787fdae363&tochange=ca4d8bb54e7f
bug 485889 was a major correctness fix that landed in the fixed range (if I'm understanding comment 18 correctly).

Comment 20

9 years ago
485889 looks more like a crash fix to me.
indeed it's been fixed by fixing bug 485889:
using builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/tracemonkey-win32/

fails:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090330 Minefield/3.6a1pre ID:20090330170312
http://hg.mozilla.org/tracemonkey/rev/82437f1743a1
works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090330 Minefield/3.6a1pre ID:20090330173503
http://hg.mozilla.org/tracemonkey/rev/949b20b7fd94

=> range:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=82437f1743a1&tochange=949b20b7fd94
Keywords: regressionwindow-wanted

Comment 22

9 years ago
I stand corrected. The trophy goes to waldo. xtc4uall, want to dup this against that bug and mark it verified?
perhaps a whiteboard note and dependancy is sufficient here ...
Status: RESOLVED → VERIFIED
Depends on: 485889
Whiteboard: [fixed by bug 485889]

Comment 24

9 years ago
(In reply to comment #17)
> (In reply to comment #13)
> > If we fixed this I think we should identify the patch that did it. This was a
> > major correctness bug.
> 
> We also need a test - as far as I know we have no test coverage for this issue
> and it's high visibility.

I think we're good. Waldo landed a test to cover the bug.

Updated

9 years ago
Flags: blocking1.9.2?
You need to log in before you can comment on or make changes to this bug.