The default bug view has changed. See this FAQ.

Page Info does not display any information about video stream from video tag

RESOLVED FIXED in seamonkey2.8

Status

SeaMonkey
Page Info
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Georg Maaß, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.8
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.8 fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090313 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090313 SeaMonkey/2.0b1pre

When a video stream is displayed on the the page being provided via video tag, I expect to find information about that video stream in the Page Info on tab media, but there it does not appear.

The page http://air.mozilla.com/europe/ contains a video element with src="http://icecast.mozilla.org/maow.ogv"; the video is displayed correctly on the web page, but no information about the video is provided in the Page Info on tab media.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 470629
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090328 SeaMonkey/2.0b1pre
Status: UNCONFIRMED → NEW
Component: General → Page Info
Ever confirmed: true
OS: Mac OS X → All
QA Contact: general → page-info
Version: unspecified → Trunk
Also see Bug 448630, that's the Firefox version of this bug here.
(Assignee)

Updated

8 years ago
Depends on: 448630
(Assignee)

Updated

8 years ago
Duplicate of this bug: 501331
(Assignee)

Updated

8 years ago
(Assignee)

Updated

5 years ago
Blocks: 467530
(Assignee)

Comment 4

5 years ago
Created attachment 580432 [details] [diff] [review]
Patch v1.0 Straight port.

This is a SeaMonkey port of Firefox Bug 448630 and dependencies.
http://www.seamonkey-project.org/dev/project-areas lists db48x as the owner of the SeaMonkey PageInfo code so setting review flags appropriately.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #580432 - Flags: review?(db48x)
(Assignee)

Comment 5

5 years ago
Comment on attachment 580432 [details] [diff] [review]
Patch v1.0 Straight port.

Switching requestee.
Attachment #580432 - Flags: review?(db48x) → review?(neil)

Comment 6

5 years ago
Comment on attachment 580432 [details] [diff] [review]
Patch v1.0 Straight port.

>+  else if (item instanceof HTMLAudioElement && isProtocolAllowed) {
>+    newImage = new Audio;
>+    newImage.id = "thepreviewimage";
>+    newImage.src = url;
>+    newImage.controls = true;
Please turn buffering off for audio elements by specifying newImage.preload = "metadata"; (this is the default for video elements). r=me with that fixed.

>+  if ((width != physWidth || height != physHeight) && !isAudio)
[Not sure what the point is since we never set a width for audio elements.]
Attachment #580432 - Flags: review?(neil) → review+
(Assignee)

Comment 7

5 years ago
Created attachment 583171 [details]
Patch v1.1 as checked in. r=Neil

> Please turn buffering off for audio elements by specifying
> newImage.preload = "metadata"; (this is the default for video elements).
> r=me with that fixed.
Fixed.

>> +  if ((width != physWidth || height != physHeight) && !isAudio)
> [Not sure what the point is since we never set a width for audio elements.]
Fixed.

Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/4210984aef0b
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.8: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.8
No longer blocks: 467530
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.