Closed Bug 485747 Opened 13 years ago Closed 13 years ago

Feature request: index bookmarked pages

Categories

(Firefox :: Bookmarks & History, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 342916

People

(Reporter: tjwolf, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Some folks, like me, are too lazy to organize our mail, bookmarks, etc. in folders.  In the case of firefox, folks like us end up with a humongous folder of bookmarks that becomes nearly useless for the purpose it was intended: a place to store AND FIND pages that we found interesting and want to revisit.  How to improve Firefox to help us poor folks?

The answer is easy enough and has two parts:
1) at the time that a page is bookmarked, parse the page (it's already loaded anyway) for non-trivial keywords) and build a mapping between them and the bookmarked URL.
2) Add another entry to the existing "Search" combobox: "Search in Bookmarks".  When this is made the current search, the words entered are then matched against the database built in (1) and all the bookmarks/URLs that qualify are shown by some sort of relevancy ranking on the current browser page.  The user can then simply click on the desired one.

Imagine how effective this could be: a single click on the "Bookmark this page" star adds a bookmarked page to the "database" and managing ones bookmarks is a matter of simply entering a few words remembered from the bookmarked page!


Reproducible: Always

Steps to Reproduce:
Not applicable - feature request.
Actual Results:  
Not applicable - feature request.  See details.

Expected Results:  
Not applicable - feature request.

I think this could be a really cool, differentiating feature for Firefox.  As far as I know, no other browser can do this and I am certain that it would be extremely useful/usable.

The only open question, for me, is whether the browser should occasionally reach out to the bookmarked pages and re-index for keywords.  I'm not sure if that's necessary, or even desirable, since dynamically generated web pages might have drastically different content from one time to the next and if I bookmark a page because, at that time, it had something about cats, then when I search for "cats", I expect that bookmarked page to show up - irrespective of whether it still has information about cats.

I really hope you'll consider this feature.

Best regards,
Thomas Wolf
what are you asking is basically fulltext indexing of bookmarked pages.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 342913
or also bug 342916, even more specific
I guess it is a duplicate of these bugs (which don't seem to have garnered a lot of interest since they've been written in 2006), but my bug description is a bit more specific in its suggestion of an implementation - hopefully that will help it be moved along.  I made this bug a duplicate of 342916 as well so that when someone works on that bug can see my suggestions.  342913 tries to solve a more general issue anyway.
Duplicate of bug: 342916
You need to log in before you can comment on or make changes to this bug.