"make uploadsymbols" and MOZ_PKG_PRETTYNAMES=1 don't play nice on Mac

RESOLVED FIXED

Status

defect
RESOLVED FIXED
11 years ago
Last year

People

(Reporter: nthomas, Assigned: ted)

Tracking

({fixed1.9.1})

Trunk
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

In a test release run for 3.5b4:
 make uploadsymbols
  in dir /builds/moz2_slave/macosx_build/build/obj-firefox/ppc (timeout 1200 secs)
with
 MOZ_PKG_PRETTYNAMES=1
 MOZ_PKG_VERSION=3.5b4
yields
 /builds/moz2_slave/macosx_build/build/toolkit/crashreporter/tools/upload_symbols.sh ./dist/Firefox 3.5 Beta 4.crashreporter-symbols.zip
 Transferring symbols... ./dist/Firefox
 ./dist/Firefox: not a regular file
 make: *** [uploadsymbols] Error 1
So it's dying on the spaces in human friendly name for the release.

Earlier 'make buildsymbols' has yielded a dist/Firefox.zip via
  cd ./dist/crashreporter-symbols && \
          zip -r9D ../Firefox 3.5 Beta 4.crashreporter-symbols.zip .
	zip warning: name not matched: 3.5
	zip warning: name not matched: Beta
	zip warning: name not matched: 4.crashreporter-symbols.zip

Looks like
  http://mxr.mozilla.org/mozilla1.9.1/source/toolkit/mozapps/installer/package-name.mk#127
doesn't work so well for non-app files.
This blows the run up before calling 'make package' so is moderately painful. Linux and Windows are OK - they produce firefox-3.5b4.crashreporter-symbols.zip
Fallout from bug 478221. Probably just need to add some quotes in the right places.
Assignee: nobody → ted.mielczarek
Blocks: 478221
I didn't test this on Mac, but I tested it on Windows using:
make buildsymbols uploadsymbols PKG_BASENAME="Firefox Awesome 3.x"

and it seemed to work just fine.
Attachment #370181 - Flags: review?(benjamin)
Attachment #370181 - Flags: review?(benjamin) → review+
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/78fb9a173674
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Works well in my release test run.
Comment on attachment 370181 [details] [diff] [review]
add some quoting

Simple patch, fixes a regression we introduced that breaks "uploadsymbols" for release builds.
Attachment #370181 - Flags: approval1.9.1?
Blocks: 486459
Comment on attachment 370181 [details] [diff] [review]
add some quoting

a191=beltzner
Attachment #370181 - Flags: approval1.9.1? → approval1.9.1+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.