Firefox crashes when you print a second url

RESOLVED DUPLICATE of bug 460963

Status

()

Core
Printing: Setup
RESOLVED DUPLICATE of bug 460963
9 years ago
9 years ago

People

(Reporter: John Frankel, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

If you print something in Firefox, then go to another url and try and print something else, Firefox abends. It does this every time on my machine (I don't have access to any other iMacs so I don't know if it happens elsewhere).

Reproducible: Always

Comment 1

9 years ago
I've been experiencing this too - since I switched to the Firefox 3.5 beta, it will crash the second time I try to print. The first time it works fine, the second time, the browser instantly crashes when I choose "File -> Print".

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

My machine is an Apple MacBook aluminum; My default printer is a Canon MP620.

Comment 2

9 years ago
I have Mac OS 10.5.6.  Canon MX850 Multifunction device installed and connected through USB.  I tried the solution posted at 

https://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&forumId=1&comments_threshold=0&comments_parentId=198280&comments_offset=40&comments_per_page=20&thread_style=commentStyle_plain

Which says:
Thanks guys...I have just figured this out. 
To fix your printer/crash problem 
type "about:config" (without the quotation marks) on your address bar 
Hit "enter". Go down to your "print, print, printer" (I forget the exact words) 
Right clik and "reset" 
Close Firefox and restart. Voila!!1 you can print again

It worked for a few printing cycles, but then started crashing again after the second print.

Comment 3

9 years ago
Regarding comment #2, I've tried this several times and it does not work for me.  I use Firefox 3.0.10 running on iMac using Intel Mac OS X10.5.  Also, I disabled each one of my plug-ins, tested each one until all were disabled.  Still the second printing causes Firefox to crash.  I am printing to a Canon PIXMA MP620.  Judging from the post at this forum, it appears this problem is isolated to Macs.  Hope more people vote for a fix to encourage fixing this dreaded bug.  My current workaround is to use Firefox most of the time and switch to Safari after I fail to print.

 http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_threshold=0&comments_parentId=198280&comments_offset=40&comments_per_page=20&thread_style=commentStyle_plain

Comment 4

9 years ago
Love this work around as noted near the end of the line I referred to in #2. 

"mm

same problem here..

i just tried something that i thought it might have fixed it...i changed the default printer from my Canon to something else - in this case i added adobe pdf 8...

goto apple/system preferences/print & fax

add printer - select any (i had the options of adobe pdf, pdf 7, pdf 8)...under "print using" just select any driver and click add...and just make sure that this is the new 'default' printer - right click "set as default"

hope that helps."

It certainly helped me.  Mac users, register and vote to have Canon/Mozilla collaborate and fix this vicious bug.

Comment 5

9 years ago
Oops!  Clarification in comment #4.  I meant refer to comment #3.

Comment 6

9 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Component: General → Printing: Setup
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: general → printing.setup
Summary: Firefox abends when you print a second url → Firefox crashes when you print a second url
Whiteboard: DUPEME
Version: unspecified → 1.9.1 Branch

Comment 7

9 years ago
I've switched to Opera for Mac.  I'm very happy with it.

Comment 8

9 years ago
reporter: you didn't specify which printer. We really need you to indicate your printer and follow the instructions from:
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

Abe, Robert: it wouldn't shock me if there's a problem w/ canon's printer driver, but again, we really need a stack trace, please follow the instructions.

Comment 10

9 years ago
thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 460963

Comment 11

9 years ago
Has happened with all versions of FF & OS X since I bought Canon Pixma 4500 in February 2008. Extremely irritsting. I now use Safari if I know I will need to print anything having lost vital information previously. Anyone from Mozilla interested?

Many crash reports sent.

Thanks
You need to log in before you can comment on or make changes to this bug.