Closed Bug 486308 Opened 11 years ago Closed 10 years ago

files in downloads window have the folder icon

Categories

(Toolkit :: Downloads API, defect, minor)

x86
Windows Vista
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 454247

People

(Reporter: u342559, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

After I enabled tracemonkry for XUL, everything in the downloads window has the windows folder icon.

Reproducible: Always

Steps to Reproduce:
1. set javascript.options.jit.chrome = true
2. download something
3. repeat step 1 until a few more items show up in the downloads window

Actual Results:  
All of them have the icon used by Windows folders.

Expected Results:  
Their respective icons, depend on the file type.

Theme: Office 2007 Black
Didn't test the default theme, but everything works fine after I turned off Tracemonkey for XUL.
Summary: all files in downloads window have the folder icon after enabled tracemonkey for xul/chrome → files in downloads window have the folder icon
Just realized that no matter I turn on or off Tracemonkey, same bug remains.
Tested default theme and it doesn't help.
Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

Confirming that bug.
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
Sound like dupe of Bug 454247
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454247
You need to log in before you can comment on or make changes to this bug.