Download manager shows wrong icon for downloads if path to download folder contains non-ascii characters

RESOLVED DUPLICATE of bug 415761

Status

()

RESOLVED DUPLICATE of bug 415761
11 years ago
10 years ago

People

(Reporter: bugmozz, Unassigned)

Tracking

({intl, regression})

Trunk
x86
Windows XP
intl, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Posted image screenshot
range : 20080827-20080828 Nightly (Windows)

wrong icon appears, sometimes it's a folder icon, sometimes HDD drive icon.

this seems to happen when files are saved in 2-byte character name directory.

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090408 Minefield/3.6a1pre

I can reproduce this bug.

load http://www.commeca.co.jp/president/images_p/%E7%9F%A5%E5%BA%8A.jpg
save to C:\Documents and Settings\username\My Documents\Downloads\
result:wrong icon(folder icon)

load http://www.mozilla.com/img/tignish/home/feature-logo.png
save to C:\Documents and Settings\username\My Documents\Downloads\
result:normal icon(Windows Picture and Fax Viewer icon)

load http://www.commeca.co.jp/president/images_p/%E7%9F%A5%E5%BA%8A.jpg
save to C:\Documents and Settings\username\My Documents\Downloads\ダウンロード\
result:wrong icon(folder icon)

load http://www.mozilla.com/img/tignish/home/feature-logo.png
save to C:\Documents and Settings\username\My Documents\Downloads\ダウンロード\
result:wrong icon(folder icon)
Duplicate of this bug: 486308
Duplicate of this bug: 499663
Tweaking summary.
Summary: Wrong icon appears on DM → Download manager shows wrong icon for downloads if path to download folder contains non-ascii characters
Keywords: intl

Comment 5

10 years ago
normal: moz-icon://file:///C:/tmp/%D1%8B/somefile.png?size=32
wrong: moz-icon://file:///C:/tmp/somefile.png?size=32

Regression from Bug 422776?

Comment 6

10 years ago
Sorry, I mean
wrong: moz-icon://file:///C:/tmp/%D1%8B/somefile.png?size=32
normal: moz-icon://file:///C:/tmp/somefile.png?size=32
(Reporter)

Comment 8

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090630 Minefield/3.6a1pre ID:20090630044527

seems to be fine.
Resolving per comment #8.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415761
Duplicate of this bug: 501958
You need to log in before you can comment on or make changes to this bug.