Closed Bug 48651 Opened 22 years ago Closed 22 years ago

input type=button will not display unless wrapped by a form tag in build 17

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 50070

People

(Reporter: bhunt, Assigned: harishd)

Details

the following input element does not render unless nested inside a form 
element.  Used to render in build 16.  input type=text and select elements
display correctly.
-----------------------------------------------------------

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 
Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
</head>

<body>
<input type="button"
       value="test"
       onclick="alert('ah.. you found me')" />
</body>
</html>
Very true... IE 5 does this. Is it in the spec?

<makes note to self to read HTML 4 spec sometime>

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
I doesn't render because it isn't getting into the content model. If I dump the 
content model I get:

docshell=0137EEA0
html@02733208 refcount=3<
  head@027325B8 refcount=2<
  >
  body@0277DF28 refcount=3<
  >
>

reassigning
Assignee: rods → harishd
Okay, this is a strict DTD issue. 

Note: Strict DTD will not be supported in mozilla. This bug should go off once 
strict DTD is yanked.  Btw, I see the button "test" in my tree ( with strict DTD 
off ).

Here is the content model:

docshell=01C7BEA0
html@01CBBC58 xmlns=http://www.w3.org/1999/xhtml xml:lang=en refcount=3<
  head@01CBCCC8 refcount=2<
  >
  Text@0325BB90 refcount=3<\n>
  body@0325C138 refcount=3<
    Text@03394EC0 refcount=3<\n>
    input@033979EC type=button value=test onclick=alert('ah.. you found me') 
refcount=4<>
    Text@033867D0 refcount=3<\n>
  >
>
Status: NEW → ASSIGNED
This bug would go away when bug 50070 gets fixed. Marking it a dupe of 50070 (
though it's not exactly a dupe ).

*** This bug has been marked as a duplicate of 50070 ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Updating QA contact.
QA Contact: ckritzer → bsharma
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.