[STRICT DTD] remove Strict DTD parsing

VERIFIED FIXED

Status

()

Core
HTML: Parser
P2
blocker
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: ekrock's old account (dead), Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP2] fix waiting)

(Reporter)

Description

18 years ago
Strict DTD parsing must be removed for nsbeta3. Assigning to harishd. Harish, if
this is a DUP, just close it. Thanks!
(Reporter)

Comment 1

18 years ago
Marking [nsbeta3+].
Keywords: donttest, nsbeta3
Whiteboard: [nsbeta3+]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [nsbeta3+] → [nsbeta3+] fix waiting
(Assignee)

Comment 2

18 years ago
RickG has a fix in his tree, awaiting a good time to check in.

Updated

18 years ago
Blocks: 42525
Severity: normal → blocker

Comment 3

18 years ago
*** Bug 42525 has been marked as a duplicate of this bug. ***

Updated

18 years ago
No longer blocks: 42525

Comment 4

18 years ago
Could I ask that this be made a pref, at least in Mozilla even if not in NS6?
(I'm fine with defaulting it to off, even for Moz). As a web developer, I want
very much to be *aware* when I break the standards so I can fix them. A pref
that would cause pages to "really break" when I violated the standards, rather
than going into fallback mode, would be a godsend.

The ideal, of course, would be a fix for bug 42286, but please don't remove the
one way developers still *do* have to see when they break the standards.

Comment 5

18 years ago
*** Bug 48114 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 48651 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
*** Bug 48114 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
*** Bug 50985 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
*** Bug 50985 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
*** Bug 50985 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
*** Bug 16934 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

18 years ago
*** Bug 50692 has been marked as a duplicate of this bug. ***
Harish, Rick: Can you check this in please? This is masking a lot of other
bugs and is causing a lot of duplicates and is generally a pain for QA.

Thanks...
Keywords: mostfreq
Priority: P3 → P2
(Assignee)

Comment 14

18 years ago
It's ready, awaiting a preceeding checkin from Vidur.
Vidur? And news on your checkin that is blocking this bug?

(Is there a bug number we can put in the 'depends on' field for this bug?)

Comment 16

18 years ago
PDT agrees P2 after talking to rickg
Whiteboard: [nsbeta3+] fix waiting → [nsbeta3+][PDTP2] fix waiting

Comment 17

18 years ago
This should not be waiting on anything from me. Based on the response to David
and Ian's question to the HTML WG, the only change that needs to happen is in
the parser. We don't have to do any sniffing for documents delivered as
text/html - all such documents should go through exactly the same codepath -
NavDTD and HTMLContentSink.

Rick and I spoke about this several days ago. At the end of the conversation, I
assumed he understood that there was no need for code change outside the parser.
(Assignee)

Comment 18

18 years ago
Rick understood perfectly. At the time of the comment, we were still awaiting 
Vidur's changes. Then the decision to use the html codepath was made. We're no 
longer waiting on vidur, and I'm prepared to land the change momentarily.
(Assignee)

Comment 19

18 years ago
Done.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.