Last Comment Bug 486842 - Can't add additional Recipients (To: Cc: Bcc: Lines) in MailNews
: Can't add additional Recipients (To: Cc: Bcc: Lines) in MailNews
Status: RESOLVED FIXED
: fixed1.9.0.11, fixed1.9.1, regression, verified1.8.1.22
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: x86 All
: -- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 486867 486987 (view as bug list)
Depends on: 486848
Blocks: 432068
  Show dependency treegraph
 
Reported: 2009-04-04 08:58 PDT by Tobias Fischer
Modified: 2009-06-02 15:46 PDT (History)
13 users (show)
dveditz: blocking1.8.1.next+
dveditz: wanted1.8.1.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tobias Fischer 2009-04-04 08:58:06 PDT
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090403 Mnenhy/0.7.5.20005.h2 SeaMonkey/2.0b1pre

Build ID: 20090403121852, Changeset:
http://hg.mozilla.org/comm-central/rev/4f871c9ec5f8
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/dbb9e2e53ea6

This is the first Build were it was not possible to add another To: Cc: Bcc: or Newsgroup: Line into the Addresspane, neither Return, nor Mouse will do this Job. 
Todays Thunderbird-Nightly is affected too. 

Last known good Build ID: 20090403124907, Changeset:
http://hg.mozilla.org/comm-central/rev/809750e4c971
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/0c9cb75bc9ba

so comm-central Checkin for Bug 194788 or mozilla-central Checkin for Bug 432068 must have caused this regression.
Comment 1 Phil Ringnalda (:philor) 2009-04-04 10:12:54 PDT
STR:

1. Build Thunderbird with comm-central+mozilla1.9.1 updated to -r default
2. Run Tb (in a profile that will let you compose without arguing), click the Write button on the toolbar.
3. In the "To:" textbox, type a@b.com, press return
4. Note that nothing happened, in particular that you didn't get a second "To:" added below the first, and focus didn't go to the second row of the addresswidget
5. cd mozilla && hg update -r 0c9cb75bc9ba to get back before the checkin for bug 432068, build, repeat, at step 4 note that you get a second row added and focus goes there.
Comment 2 Phil Ringnalda (:philor) 2009-04-04 15:22:35 PDT
*** Bug 486867 has been marked as a duplicate of this bug. ***
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2009-04-04 20:17:49 PDT
I'm hoping the patch in bug 486848 will fix this; building comm-central to test that, but won't have results till tomorrow.
Comment 4 Nir 2009-04-05 05:21:29 PDT
As per my observation, an workaround is :

Use Address Book side bar to add any entry in To bar. Now you can add new entries using Enter button.
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2009-04-05 07:36:38 PDT
Yeah, the patch in bug 486848 fixes this.
Comment 6 Phil Ringnalda (:philor) 2009-04-05 18:26:37 PDT
*** Bug 486987 has been marked as a duplicate of this bug. ***
Comment 7 Boris Zbarsky [:bz] (Out June 25-July 6) 2009-04-05 21:02:31 PDT
Fixed by checkin for bug 486848.
Comment 8 Tobias Fischer 2009-04-05 21:59:37 PDT
Verified=Fixed, tested with actual Win and Linux Tinderbox-Builds. Since I am not an official QA, someone other should change the status.
Comment 9 Daniel Veditz [:dveditz] 2009-06-02 14:19:44 PDT
This fix is rolled into the branch patches in bug 432068, adding fixed keywords here for branch verification.
Comment 10 Al Billings [:abillings] 2009-06-02 15:46:01 PDT
Verified for 1.8.1.22 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.22pre) Gecko/2009060204 Thunderbird/2.0.0.22pre.

Note You need to log in before you can comment on or make changes to this bug.