Closed Bug 486954 Opened 11 years ago Closed 11 years ago

make standalone message respect mail.delete_matches_sort_order and advance also for the imap mark-as-deleted model

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch proposed fix (obsolete) — Splinter Review
Currently the standalone message window doesn't advance when a message is deleted. It doesn't respect mail.delete_matches_sort_order when selecting the next message either.

As for the js changes, I'm not really sure why gCurrentMessageIsDeleted has been used at all (it's been there since v 1.4... no bug in the cvs blame). AFAIKT, it's supposed to not advance in case delete/move failed. However, at least nowadays with delete/move in the background that method won't get called until too late to do the right thing anyway. Didn't see much reason to keep it around so I removed it.
Attachment #371157 - Flags: superreview?(neil)
Attachment #371157 - Flags: review?(bienvenu)
Attachment #371157 - Flags: superreview?(neil) → superreview+
Seems not to break anything and at least for me seems to work as advertised.
Attached patch proposed fix, v2Splinter Review
Unbitrotted. Carrying fwd sr=neil
Attachment #371157 - Attachment is obsolete: true
Attachment #372923 - Flags: superreview+
Attachment #372923 - Flags: review?(bienvenu)
Attachment #371157 - Flags: review?(bienvenu)
Comment on attachment 372923 [details] [diff] [review]
proposed fix, v2

seems to work as advertised, thx for the patch.
Attachment #372923 - Flags: review?(bienvenu) → review+
changeset:   2415:69cadf298d50
http://hg.mozilla.org/comm-central/rev/69cadf298d50

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 481841
I'm not sure if this bug fixes two issues, but would this fix bug 65823?
No, this bug doesn't fix that. 
This bug just advances in the preferred direction but doesn't do anything special wrt deleted status of the next message.
Duplicate of this bug: 238100
Depends on: 519128
You need to log in before you can comment on or make changes to this bug.