Drag'n'drop attachments out of Shredder results in zero length files

RESOLVED DUPLICATE of bug 458159

Status

RESOLVED DUPLICATE of bug 458159
10 years ago
8 years ago

People

(Reporter: steffen.wilberg, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090406 Shredder/3.0b3pre, Shredder nightly running on Vista 64.

Drag'n'drop of attachments from the message reader to the desktop or file folders (i.e. outside Shredder) results in zero length files. Right-clicking and choosing "Save As..." works fine.

This happens every time with Shredder nightlies, but works fine in Thunderbird 2.0.x.

Related bugs I found are bug 377621 (but reported as Linux only), bug 375728 (but that was also reported on 2.0 branch) and bug 384590 (but that's 2.0 branch only).
Flags: blocking-thunderbird3?
(Reporter)

Comment 1

10 years ago
This already happens in Thunderbird 3a1 from May 2008, with the difference that Windows displays a "moving..." status window with a progress bar, then a message in the windows task bar that Thunderbird was closed because of Data Execution Prevention, although that doesn't close Thunderbird.
It still results in a zero length file.

The 2007-06-01 trunk nightly displays the same "moving..." status window, but no message regarding to Data Execution Prevention.
It results in no file at all.

The 2006-06-01 trunk nightly (ugh, is that ugly!) drops a file called "INBOX4175" with zero length.
Probably a duplicate of bug 458159?
Whiteboard: DUPEME
(Reporter)

Comment 3

10 years ago
Yeah, could be it.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-thunderbird3?
Resolution: --- → DUPLICATE
Duplicate of bug: 458159
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.