Update preview.amo database for QA

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: clouserw, Assigned: reed)

Tracking

Details

(Reporter)

Description

9 years ago
QA needs to verify bugs.  Please make sure all of the 5.0.4 database updates are run on preview.amo:

https://wiki.mozilla.org/Update:Developers/Database_Changes#5.0.4
(Assignee)

Comment 1

9 years ago
Does this conflict with bug 487321?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Does this conflict with bug 487321?

Yep, I wasn't CC'd on that bug.  This one is a superset so let's go with this one.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 487321
(Assignee)

Updated

9 years ago
Assignee: server-ops → reed
(Assignee)

Comment 4

9 years ago
mysql> ALTER TABLE addons ADD COLUMN nominationdate DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00';
Query OK, 8234 rows affected (1.87 sec)
Records: 8234  Duplicates: 0  Warnings: 0

mysql> UPDATE addons SET nominationdate = modified;
Query OK, 6706 rows affected (0.29 sec)
Rows matched: 8234  Changed: 6706  Warnings: 0

mysql> ALTER TABLE users 
    ->  ADD COLUMN 
    ->    `resetcode` VARCHAR(255) NOT NULL DEFAULT "" AFTER `confirmationcode`,
    ->  ADD COLUMN 
    ->    `resetcode_expires` DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00' AFTER `resetcode`;
Query OK, 3271698 rows affected (4 min 24.94 sec)
Records: 3271698  Duplicates: 0  Warnings: 0
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.