Closed Bug 487717 Opened 13 years ago Closed 9 years ago

browser_bug435788.js times out

Categories

(Toolkit Graveyard :: Plugin Finder Service, defect)

1.9.1 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: robert.strong.bugs, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(3 files)

Whiteboard: [orange]
Depends on: 435788
Will take care of these in a single patch
No longer blocks: 438871
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487489
No longer depends on: 435788
Whiteboard: [orange]
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 438871
Whiteboard: [orange]
Thanks for coming to the tree health talk!  I'm assigning you a semi-randomly selected intermittent, feel free to reassign, but feel MORE free to fix it.  :)

This is reopened, but a dup of another bug... is it fixed now?
Assignee: nobody → dtownsend
(In reply to comment #2)
>...
> This is reopened, but a dup of another bug... is it fixed now?
The other bug was for a different issue
Seems that this times out in different tests including 1, 2, 5, 6 and maybe 8. Some logs to go on:

This hasn't happened since May 1st though.

WIN mozilla-central
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1238622998.1238632517.26836.gz&fulltext=1 (Test 1, 04/01)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1240012614.1240018403.6742.gz&fulltext=1 (Test 2, 04/17)

OSX mozilla-central
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241193735.1241198768.10641.gz&fulltext=1 (Test 5, 05/01)

WIN mozilla-1.9.1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1239314748.1239321210.13947.gz&fulltext=1 (Test 6, 04/09)

OSX mozilla-1.9.1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1239618773.1239621859.23445.gz&fulltext=1 (Test 5, 04/13)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1239801038.1239805620.11722.gz&fulltext=1 (Test 5, 04/15)

LINUX mozilla-1.9.1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1239882735.1239888765.16624.gz&fulltext=1 (Test 8, 04/16) ** This might be a different failure
Summary: browser_bug435788.js Timed out on Test 6 → browser_bug435788.js times out
So it looks like either we aren't seeing a load event from opening the PFS dialog, or something actually is wrong and the PFS isn't finding any plugins occasionally. This patch makes some changes so we can see which it is, mainly logging when the dialog has loaded and moving the event listener registration up so we should definitely see which page the dialog switches to shortly after load.

This will likely change the failure type of this test to be real errors as opposed to timeouts since I'm guessing the load event is working fine.
Attachment #377417 - Flags: review?(robert.bugzilla)
Attachment #377417 - Flags: review?(robert.bugzilla) → review+
Comment on attachment 377417 [details] [diff] [review]
additional logging [checked in]

Landed:
http://hg.mozilla.org/mozilla-central/rev/6b7f541d848a
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4be322ea507d
Attachment #377417 - Attachment description: additional logging → additional logging [checked in]
For some reason this still hasn't shown up since May 1st. I've spotted that some of my previous changes could have hidden a failure in some of the cases so I'd like to land this that verifies that we saw the list of available plugins to install when appropriate. If it still isn't showing up after that though we might as well close this as WFM I think.
Attachment #383667 - Flags: review?(robert.bugzilla)
Comment on attachment 383667 [details] [diff] [review]
more tests [checked in]

Looks fine
Attachment #383667 - Flags: review?(robert.bugzilla) → review+
I'm going to close this for now. This test hasn't failed since July apart from 3 occasions on the same day at around the same time when a large number of tests failed which looks to be a machine issue.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → WORKSFORME
I'm reopening this based on the above (comment 11) but note that this might also be an OOPP problem - from the log:

TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | PFS loaded
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have found 1 plugin to install
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
WARNING: waitpid failed pid:2209 errno:10: file /builds/slave/mozilla-central-linux-debug/build/ipc/chromium/src/base/process_util_posix.cc, line 233
--DOMWINDOW == 118 (0xc89a634) [serial = 2371] [outer = 0xc3c5c40] [url = about:crashes]
--DOMWINDOW == 117 (0xc141bc4) [serial = 2370] [outer = 0xc3c5c40] [url = about:crashes]
--DOMWINDOW == 116 (0xc3c5c74) [serial = 2368] [outer = (nil)] [url = about:crashes]
--DOMWINDOW == 115 (0xbb7dadc) [serial = 2363] [outer = 0xb88aa10] [url = about:crashes]
--DOMWINDOW == 114 (0xb88aa44) [serial = 2361] [outer = (nil)] [url = about:crashes]
--DOMWINDOW == 113 (0xb421a24) [serial = 2344] [outer = 0xb9e5298] [url = data:text/html,...]
--DOMWINDOW == 112 (0xbb1c834) [serial = 2335] [outer = 0xc06dbf0] [url = about:blank]
--DOMWINDOW == 111 (0xc06dc24) [serial = 2334] [outer = (nil)] [url = chrome://browser/content/browser.xul]
--DOMWINDOW == 110 (0xa4b0bdc) [serial = 2328] [outer = 0xb9e5298] [url = about:blank]
--DOMWINDOW == 109 (0xb9e52cc) [serial = 2263] [outer = (nil)] [url = data:text/html,...]
--DOMWINDOW == 108 (0xc42e26c) [serial = 2379] [outer = 0xb2f34e0] [url = about:blank]
--DOCSHELL 0xbcdd710 == 12
--DOMWINDOW == 107 (0xb2f3514) [serial = 2378] [outer = (nil)] [url = about:blank]
--DOCSHELL 0x9e900e0 == 11
--DOCSHELL 0xb74ca18 == 10
--DOMWINDOW == 106 (0xbf97564) [serial = 2375] [outer = 0xbafe148] [url = about:blank]
--DOMWINDOW == 105 (0xbafe17c) [serial = 2374] [outer = (nil)] [url = chrome://mozapps/content/extensions/list.xul]
--DOCSHELL 0xcb98840 == 9
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Timed out
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Duplicate of this bug: 560878
Attachment #383667 - Attachment description: more tests → more tests [checked in]
This adds even more logging to the testcase to try to narrow down why closing the window doesn't work. We can fall back to just using window.close but it'd be nice to know why this is failing first.
Attachment #443478 - Flags: review?(robert.bugzilla)
Comment on attachment 443478 [details] [diff] [review]
even more logging

>+function pfs_loaded() {
>+  info("PFS loaded");
>+  gPFS.document.documentElement.addEventListener("pageshow", page_shown, false);
>+  gPFS.document.documentElement.addEventListener("wizardfinish", function() {
>+    info("wizardfinish event");
>+  }, false);
>+  gPFS.document.documentElement.addEventListener("wizardnext", function() {
>+    info("wizardnext event");
>+  }, false);
>+  gPFS.addEventListener("unload", function() {
>+    info("unload event");
>+  }, false);
>+  gPFS.document.documentElement.addEventListener("pageshow", page_shown, false);
added twice (see above)

note: there are a couple of event listeners that are added and not removed... that's ok for debugging this time out but don't forget to clean this up later

r=me with that fixed
Attachment #443478 - Flags: review?(robert.bugzilla) → review+
No longer blocks: win_unittests_minis
Dave, you are probably interested in knowing this is absolutely reproduceable on an Ubuntu64 VM.
It stucks in the Plugin Finder Service, Available Plugin Downloads. Test Plugin 1 is selected and this window has focus.
[19:50]	<mak>	JavaScript error: chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js, line 26: list is null
[19:50]	<mak>	var list = gPFS.document.getElementById("pluginList");
(In reply to comment #20)
> Dave, you are probably interested in knowing this is absolutely reproduceable
> on an Ubuntu64 VM.
> It stucks in the Plugin Finder Service, Available Plugin Downloads. Test Plugin
> 1 is selected and this window has focus.

Is this still the case? Would you be able to get me the log from a run like that?
No longer blocks: win7-32bit-oranges
Assignee: dtownsend → nobody
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: REOPENED → RESOLVED
Closed: 12 years ago9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.