Closed Bug 560878 Opened 10 years ago Closed 10 years ago

chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js times out on Fedora

Categories

(Release Engineering :: General, defect, P2)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 487717

People

(Reporter: armenzg, Assigned: armenzg)

References

Details

This is the last permanent-orange on mochitest-browser-chrome for Fedora.

It seems to time out.

Look for:
Rev3 Fedora 12 mozilla-central debug test mochitest-other
Rev3 Fedora 12 mozilla-central opt test mochitest-other
Rev3 Fedora 12x64 mozilla-central debug test mochitest-other
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other
on 
http://tinderbox.mozilla.org/showbuilds.cgi?tree=Firefox&noignore=1

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271864813.1271866635.10140.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271863435.1271864081.1911.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271864645.1271866536.9831.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271857367.1271857991.15001.gz&fulltext=1
No longer blocks: fedora-oranges
This might have been fixed with the gtk update and I will have to review if this ever affected the x64 machines.

I am waiting on some builds that just got triggered.
Component: Plugin Finder Service → Release Engineering
Product: Toolkit → mozilla.org
QA Contact: plugin.finder → release
Version: unspecified → other
Assignee: nobody → armenzg
Priority: -- → P2
CCing Mossop who wrote the test originall, and Rob, who reviewed it.
Can we see what is on screen at the point it times out?
OS: Mac OS X → Linux
I have checked again and these are my findings:
* This is not a perma-orange
* This seems to only happen on Fedora 32bit debug/opt mochitest-browser-chrome
* It has happened again since the gtk update (discarding the idea that it would fix it. I don't know where I got that thought from)

Mossop how could I find out what was on screen at the moment when it times out? (If it happens again)
Is there no way to watch the tests running on the boxes? I would expect the plugin finder will be on screen but knowing what page it is on and what iot says would help a lot to figure out what is going on here.
Could the test dump the page at each possible step where it hangs so it is in the log prior to the hang?
(In reply to comment #6)
> Could the test dump the page at each possible step where it hangs so it is in
> the log prior to the hang?

I can figure out what page the test is on at the last point it does something, but it then clicks next and we wait for the finder to do things. I could check in a bunch of extra logging but I was under the impression we could just look at the screen easily to get this anyway. If not I'll try to cook up some additional logging
Any progress with this? Anything that you would like me to try?
Shall I pass this bug to someone?
(In reply to comment #8)
> Any progress with this? Anything that you would like me to try?
> Shall I pass this bug to someone?

Do I take it from that that there is no way to view the screen of the timing out runs?

I'll try to work up some additional logging, probably won't happen today though.
(In reply to comment #9)
> (In reply to comment #8)
> > Any progress with this? Anything that you would like me to try?
> > Shall I pass this bug to someone?
> 
> Do I take it from that that there is no way to view the screen of the timing
> out runs?
> 
> I'll try to work up some additional logging, probably won't happen today
> though.

If this was a permanent orange it would probably be easy for me to find out what is going on. Since it is random I might not be able to hit or not to be able to know for which screen I should be looking for. Mossop I will ping you tomorrow in the morning to see if I catch it.
Status: NEW → ASSIGNED
Looking again into the errors.

I have two Fedora machines ready for someone to try to reproduce this. I don't know what to look for and/or how to make it time out purposely.

Does any of the following files/errors give you an idea of why we are timing out?
* waitpid failed pid:2178 errno:10
* ipc/chromium/src/base/process_util_posix.cc, line 233
* ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 162

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272551276.1272552423.6096.gz
NOTE: child process received `Goodbye', closing down
WARNING: waitpid failed pid:2178 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Test 2
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | PFS loaded
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have found 1 plugin to install
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
WARNING: waitpid failed pid:2178 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: waitpid failed pid:2178 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: Failed to deliver SIGKILL to 2178!(3).: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 162
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Timed out

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272541522.1272542800.23452.gz
Running chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js...
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Test 1
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | PFS loaded
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have found 1 plugin to install
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the list of available plugins
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have attempted to install 1 plugin
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the installed item
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have been a successful install
NOTE: child process received `Goodbye', closing down
WARNING: waitpid failed pid:2107 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Test 2
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | PFS loaded
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have found 1 plugin to install
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
WARNING: waitpid failed pid:2107 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: waitpid failed pid:2107 errno:10: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: Failed to deliver SIGKILL to 2107!(3).: file /builds/slave/mozilla-central-linux/build/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 162
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Timed out


http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272537534.1272538267.7999.gz
NOTE: child process received `Goodbye', closing down
WARNING: waitpid failed pid:2323 errno:10: file /builds/slave/mozilla-central-linux-nightly/build/ipc/chromium/src/base/process_util_posix.cc, line 233
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Test 2
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | PFS loaded
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have found 1 plugin to install
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
WARNING: waitpid failed pid:2323 errno:10: file /builds/slave/mozilla-central-linux-nightly/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: waitpid failed pid:2323 errno:10: file /builds/slave/mozilla-central-linux-nightly/build/ipc/chromium/src/base/process_util_posix.cc, line 233
WARNING: Failed to deliver SIGKILL to 2323!(3).: file /builds/slave/mozilla-central-linux-nightly/build/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 162
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Timed out
I'm seeing something similar on win7 machines:

WINNT 6.1 mozilla-central opt test mochitest-other
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487717
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.