If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Setting overflow style attribute of tag containing Applet causes Applet Reload

RESOLVED DUPLICATE of bug 90268

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 90268
9 years ago
7 years ago

People

(Reporter: joe larson, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.53 Safari/525.19
Build Identifier: (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

If you have javascript change the overflow style attribute of a tag which contains a Java Applet, the Java Applet will reload / call it's init() method again.  This does not happen in IE, Chrome, or Safari for Windows.

Reproducible: Always

Steps to Reproduce:
1.Stick an applet in a div, which somehow lets you know it's init() has been called (paints differently; logs to java console)
2.After applet loads, use javascript to set div.style.overflow='scroll'
3.Check if the applet has re-init()ed
Actual Results:  
Applet init()s again, wrongly

Expected Results:  
Does not init() until page reloaded

This is somewhat similar to bug 340465 but not exactly.
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

7 years ago
I have retested in 3.6.12 and it is still an issue.  As a side note, curiously I did not get an email about the original 2010-10-18 "This bug was reported using Firefox 3.0 or older, which is no longer supported" comment...
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2010-11-15]
Version: unspecified → 3.6 Branch

Updated

7 years ago
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
Version: 3.6 Branch → 1.9.2 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
You need to log in before you can comment on or make changes to this bug.